BCD Problems all over

afrob

New Member
#1
Hey,

it all startet with a bluescreen after win10 upgrade to creators update.
I used BCD before for "switching between an old and new win10 system"

Everything seems to be broken because all boot sector stuff was somehow broken, but after hours of work (reinstalling a uefi boot partition and so on and on my computer is starting again and booting into the right system.

BUT now it still does not work perfectly:
  • BCD can only be opened from system partition when i open it directly with a "drive letter" to the system partition
  • i cant use bcdedit inside cmd with administrator rights
  • i cant access msconfig -> start (nothing is there or editable)

boot1.PNG
boot3.PNG boot2.PNG



My BCD config for an UEFI System:


Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=F:
path \EFI\Microsoft\Boot\bootmgfw.efi
description Windows Boot Manager
locale de-DE
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {cdf41391-26d8-11e7-a078-8bce2066de35}
resumeobject {cdf41390-26d8-11e7-a078-8bce2066de35}
displayorder {cdf41391-26d8-11e7-a078-8bce2066de35}
{a44aa143-26de-11e7-8c7d-d050995663cd}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 3
displaybootmenu Yes

Windows Boot Loader
-------------------
identifier {cdf41391-26d8-11e7-a078-8bce2066de35}
device partition=C:
path \windows\system32\winload.efi
description Windows 10 neu
locale de-DE
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
isolatedcontext Yes
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \windows
resumeobject {cdf41390-26d8-11e7-a078-8bce2066de35}
nx OptIn
bootmenupolicy Standard

Windows Boot Loader
-------------------
identifier {a44aa143-26de-11e7-8c7d-d050995663cd}
device partition=D:
path \Windows\system32\winload.efi
description Windows 10 alt
locale de-DE
osdevice partition=D:
systemroot \Windows

Already tried this idea:
Can't access Win7 BCD

hidding did not change something.


Side effects:

I also got also side effects which are annoying after i get my system back:
  1. VSS (Volume Shadow copy errors (0x80073bc3, 0x80070005) when i try to make a full image backup inside windows (i read , if something changed in partitions of a installed windows VSS tries to access the volume on the non exisiting partition....)
  2. Windows Update is not working anymore. Cant install any new updates from MS :frowning:
    Installing the Update and then rolling it back after restart because of problems. (seems also to be that he cant write on specific areas which are blocked or not reachable like the BCD stuff)

Next stop full reinstall. But i really dont want it. So any help is appreciated.

regards
Robert
 

Terry60

Knows where his towel is.
Staff member
#3
The fact that you can access the EFI system partition with a disk letter seems to suggest that it's not correctly formatted.
Can you post a screenshot of your disk management.
 

afrob

New Member
#4
Hey,

i also tried to remove letter or hide the system partition. Did not change something. But you can be right, because i reformatted the system partition to copy boot files on the partition. That was the fact the system started again somehow. But there are still the describes problems :wink:

Sorry that the screenshots are in german. Dont know how to change in english versions of diskpart

boot4.PNG

boot5.PNG
 

mqudsi

Mostly Harmless
Staff member
#5
Do you have an MBR on this disk, or just the GPT? You can use a tool like gdisk to find out.

Having both and their being out-of-sync with one another confuses the heck out of bcdedit (and Windows in general). It was one of the toughest problems for us to fix in EasyRE, and we're still finding little gotchas we need to handle with updates and new releases.

If gdisk says you do, use it to wipe the MBR and replace it with a protective MBR instead.

Also, (and I don't think you can trust the output of diskmgmt.msc on this), make sure the guid for the boot partition is not the partition type for fat32 (which is stored as MS-DATA). So it should be {C12A7328-F81F-11D2-BA4B-00A0C93EC93B} and not {EBD0A0A2-B9E5-4433-87C0-68B6B72699C7}.
 

afrob

New Member
#6
This is the gdisk info of the disk and partitions.
What should i do now.
Gdisk is not easy to understand :wink:


Type device filename, or press <Enter> to exit: \\.\physicaldrive0
The protective MBR's 0xEE partition is oversized! Auto-repairing.

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): i
Partition number (1-3): 1
Partition GUID code: EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 (Microsoft basic data)
Partition unique GUID: 68379DBD-D152-44A5-967B-6C1CFC8788EA
First sector: 2048 (at 1024.0 KiB)
Last sector: 999049444 (at 476.4 GiB)
Partition size: 999047397 sectors (476.4 GiB)
Attribute flags: 0000000000000000
Partition name: 'Basic data partition'

Command (? for help): i
Partition number (1-3): 2
Partition GUID code: EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 (Microsoft basic data)
Partition unique GUID: 2839CA48-90FB-4F2B-AD31-C80114557CEC
First sector: 999051264 (at 476.4 GiB)
Last sector: 999997439 (at 476.8 GiB)
Partition size: 946176 sectors (462.0 MiB)
Attribute flags: 8000000000000000
Partition name: 'Basic data partition'

Command (? for help): i
Partition number (1-3): 3
Partition GUID code: EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 (Microsoft basic data)
Partition unique GUID: CA755B1E-F6A1-4083-9968-0395181857D9
First sector: 999998055 (at 476.8 GiB)
Last sector: 1000206899 (at 476.9 GiB)
Partition size: 208845 sectors (102.0 MiB)
Attribute flags: 0000000000000000
Partition name: 'Basic data partition'

Command (? for help):
 

afrob

New Member
#7
and this:

Disk \\.\physicaldrive0: 1000215216 sectors, 476.9 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): F3BE6260-BA2B-44C0-936D-A65FB4BD4B5B
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1000215182
Partitions will be aligned on 8-sector boundaries
Total free space is 12731 sectors (6.2 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 999049444 476.4 GiB 0700 Basic data partition
2 999051264 999997439 462.0 MiB 0700 Basic data partition
3 999998055 1000206899 102.0 MiB 0700 Basic data partition
 

afrob

New Member
#8
you did not answer so i try on my own :smile:
With caution but I tried:

  1. With the "t" Option i could change my partition type code With the gdisk manual i found i had to change the EFI Partition to: 0xEF00
    That code was only on the gdisk website and not in the help file
  2. Then write to the gpt table
  3. now i can edit msconfig and load BCD directly.
Thanks for your hint.

regards
Robert
 

mqudsi

Mostly Harmless
Staff member
#9
Awesome. It sounds like it was indeed a GPT issue and gdisk was able to fix the problem. Great going!