BCD working fine from HDD. I wish to use a USB stick just to boot HDDs.

#1
Firstly this is my first post here so I wish to say hi to everyone.

I am new to EasyBCD. I have 3 individual Windows 10 drives and I boot with UEFI. Using EasyBCD I now have a boot menu that waits for me to select a drive to boot from which is great. Your software has really streamlined how I have things setup.

I wondered if it was possible to use a USB memory stick with EasyBCD and hold the EFI boot instead of keeping it on a HDD drive as I do at the moment. This is just in case I killed the drive that holds the EasyBCD boot setup.

So, I did the following;

1. Using BCD Deployment - selected Drive 8, Partition 1 (G:\ as FAT32 - 15GiB)
Then hit 'Install BCD' button

2. When it asks me if I would like to load the newly created BCD store.. I select Yes

3. I then go to Add New Entry and enter the following in the Operating System section;

Name: Development
Drive: C

and repeat the process for . . .

Name: MULTIMEDIA
Drive: H

and . . .

Name: GAMES
Drive: F


4. I then go to Edit Boot Menu and select DEVELOPMENT as default.
I also select Wait for user selection.

4. I restart my PC and make sure my EFI Scandisk Cruzer is selected as the boot device.


This is the same way I sucessfully got EasyBCD working when its installed from a HDD but it does not work installed on my USB stick.

I do get a boot from the USB stick but I only get one option and the following message...
 

Attachments

Last edited by a moderator:

Ex_Brit

If you're going through hell, keep going.
Staff member
#2
Edited your post to include the image. When posting, look for the "More Options" button and then there'll be a (multi-purpose) "Upload File" button.
I can't answer the question however, I'll leave that to the experts.
 

mqudsi

Mostly Harmless
Staff member
#4
Ah, that would be because EasyBCD would load the MBR-based BCD for external devices by default. You'll need to press "no" when asked to auto-load the newly-created BCD and instead go to File | Load BCD and select the EFI BCD path. This is not \BOOT\BCD on the flash drive, it's \EFI\Microsoft\Boot\BCD instead.