bcdedit.exe /import c:\boot\bcd.temp FAIL?

#1
hello! i had set up my hp tx1000 with vista previously installed to dual boot ubuntu studio. The ubuntu distro i had sucessfully installed wasnt working so well, so i attempted to install over it another version. apparently the iso was corrupt and the installation process was a failure(although this process never made it so far as to redo anyting regarding the grub bootloader). Upon reboot i was left without a messed up vista bootloader.

I then downloaded the windows recovery disk, and followed the sucession of methods to attempt repair, to no avail. Ultimately i ended up at step 4: Nuclear Holocaust. I had no form of Bootsect.exe to access, so i installed it on a Pen drive, and substitued the command "x:\boot\bootsect.exe /nt60 all /force" for f:\bootsect.exe /nt60 all /force.

upon my first attempt, i had sucessfully rewritten the bootloader as suggested by this method, i was able to boot to windows, upon doing so immediately installed easybcd.

unfortunately after the next reboot, i was again shown "Missing operating system"

i put in the same vista reboot, followed the same process:

*=sucessful command

*bootrec.exe /fixmbr
*f:\bootsect.exe /nt60 all /force

del C:\boot\bcd (could not find)
*bcdedit /createstore c:\boot\bcd.temp
*bcdedit.exe /store c:\boot\bcd.temp /create {bootmgr} /d "Windows Boot Manager"
bcdedit.exe /import c:\boot\bcd.temp

"the store import operation has failed. the volume does not contain a recognized file system. please make sure that all required file system drivers are loaded and that the volume is not corrupted."


i get this also when attempting to add c:\windows to the boot list

Disk check yeilds no corrupt sectors, the partitions are c:windows d:ntsf
and the linux /root /home and swap.
i have also tried attrib bcd -s -h -r
and again the import command, no luck

any suggestions as to what to try to resolve this is much appreciated!
 
#2
Well just from having a quick look over it appears you deleted the BCD file then created a new one without adding any boot loader entries to it? Before importing the new BCD file try adding a boot loader so for Windows Vista try this as a batch (substite C: for the OS system drive):

Code:
set systemdrive=C:
set tempbcd=C:\boot\bcd.temp
set tempfile=C:\boot\temp.txt
 
bcdedit -createstore %tempbcd%
bcdedit.exe -store %tempbcd% -create {bootmgr} -d "Windows Boot Manager"
 
bcdedit -store %tempbcd% -create -d "Windows Vista" -application osloader>%tempfile%
set /p winvistaguid= <%tempfile%
set winvistaguid=%winvistaguid:~10,38%
 
bcdedit -store %tempbcd% -set %winvistaguid% osdevice partition=%systemdrive%
bcdedit -store %tempbcd% -set %winvistaguid% device partition=%systemdrive%
bcdedit -store %tempbcd% -set %winvistaguid% path \Windows\system32\winload.exe
bcdedit -store %tempbcd% -set %winvistaguid% systemroot \Windows
 
bcdedit -import %tempbcd%
This script will create a new boot manager file and add the Windows Vista boot loader to it, repeat the Vista part of the code as necessary for multiple OS's. You shouldnt need to run "f:\bootsect.exe /nt60 all /force" either, but if you do run it AFTER running this script.
 
#3
Hi Guys, going through the exact same stuff. I tried sseell´s awesome script, but unfortunately had trouble with the last step. When I run

bcdedit -import %tempbcd%

i get: "store import operation has failed. The requested system device cannot be found"

all of the other previous steps worked smoothly. Any idea as to what could be causing this? Not sure if this is related, but I´ve gone in through diskpart an made sure that the correct disk and partition are active.

any help would be immensely appreciated
Thank you.
 

mqudsi

Mostly Harmless
Staff member
#4
If you changed the active disk with diskpart, you'll have to restart first.
 

zArt

New Member
#5
Hi.
I have the exact same problem. I'm following the tutorial in FAQ and i came across
with the same issue.
After 'bcdedit /import c:\boot\bcd.temp' command, the result is something like:
" archive import operation as failed. it's not possible to find the system device"

any thoughts?

UPDATE:
I dont really know how but i managed to run the script posted above without issues.
But i still have the 'bootmgr is missing' error. the strange thing if i put a win 7 bootable disk in the drive,
the XP boot loader kicks in so i can boot to XP.:S
 
Last edited:

zArt

New Member
#6
UPDATE nr 2:
I guess the 'bcdedit /import' issue was fixed by running 'bootrec /fixboot' and 'bootrec /fixmbr', i run them both, i dont witch worked.
After using the Windows 7 Repair image i downloaded from the FAQ section, i made the repair, now i'm able to boot to Win 7 disk but only when i have the Repair disk in the drive when booting. If i try to boot without it i get the message that there's no bootable disk installed or something like that.
I read somewhere of someone with the same problem but i dont remember where :S gotta keep looking!
 

mqudsi

Mostly Harmless
Staff member
#7
You need to use bootsect.exe, not bootrec.
 

zArt

New Member
#8
i did.
Somehow the Win 7 boot folder was created in the XP disk. I disconnected the XP drive, to see what hapened and when i run 'bootrec /fixboot' it returns 'Element not found' and I found out that the 'bcdedit /import' issue is related to this.
I'm gonna try easybcd 2.0 now, see what gives. :smile:
 

mqudsi

Mostly Harmless
Staff member
#9
Please wait for build 91 before doing anything.
 
#10
Too late. :grinning:
Here's what i did:
- Fresh install of Windows 7.
- Win 7 boot manager or somehing like that, recognises Win XP and adds it to the boot menu.
- All is fine until i run EasyBCD 2.0, so that i could add second pre-existent Win XP i have in a partition in the Win 7 disk.
- After that the same problem again, none of the Windows boots.
- The Win 7 Boot menu only appears when booting with the Install DVD in the drive. No 'Bootmgr is missing' message however.

So, from what i've experienced and understand i'm pretty sure the problem in MY case is EasyBCD 2.0.
The first time i installed WIn 7, i run EasyBCD 1.7.2 without any issues.

I hope that my experience can help the guys that are responsible for EasyBCD to troubleshoot present and future issues that can ocurr.
Any test or something that you may want me to try, i'm at your disposal, i still have my laptop so i have time to help you help me. :smile:

I hope to here from you soon. Cya.
 

JustinW

Super Moderator
Staff member
#11
Adding a new XP entry shouldn't break the ability to boot the other OSes. Have you been changing drive letters? Build 91 is now available from [thread=642]here[/thread].

You should be able to startup repair with the W7 recovery disc to get W7 booting again following these instructions.

After this if the XP entry is working to boot one of your XP installs go to Tools > Autoconfigure boot.ini. Otherwise re-add a new entry and allow it to autoconfigure.
 

zArt

New Member
#12
Hi all.
Because of several reasons i couldn't post earlier.
The last version of EasyBCD solved my problems.
But it still isn't quite fixed or it may work like that, i just don't know:

Win 7 boot menu:

Win 7
Win XP A
Win XP B

First option boots 7 without issues.
Second or Third option takes me to the XP Boot menu where the options are:

Win XP A
Win XP B

So wherever i choose option 2 or 3 from Win 7 Boot menu it takes me to the second menu.

Any thoughts? Am i doing something wrong?

Thanks for the help. Kudos for the guys from EasyBCD.
Cya
 

JustinW

Super Moderator
Staff member
#13
You can delete the third entry. You havent done anything wrong, its part of Windows design. Both true entries for each of your XP installs are stored in boot.ini, which is presented to you with a second boot menu by XP's bootloader when it iis given control over things from W7s'.