bcdedit missing.... what now?

eredeath

New Member
So as my title says, i have lost my bcdedit program. I did this during an installation of Ubuntu (somehow) I installed grub onto the linux partition so i could use the windows bootloader (using easyBCD of course) but when i rebooted i got the ominous error "no operating system found", So i loaded up Ubuntu's disk and ran grub installing that on the master boot-loader and now i am able to log into windows and ubuntu... but i cannot repair the windows bootloader. When i try to you bcdedit i get an error telling me its an invalid command... is there a place where i can dwld this program or something?

...yep.... its messed up :smile:
 

mqudsi

Mostly Harmless
Staff member
I don't get it, if you are "able to log into windows and ubuntu" what is the problem?
 

eredeath

New Member
Why this is a problem...

i like to switch linux distros (often) i just recently removed Arch linux and had used EasyBCD for the bootloader. When i use grub and go to boot into windows i get my old bootloader asking me if i want to boot into Arch. This is a little inconvienient because i had arch set up as my default sysetm and only gave myself a 2sec window to select windows instead, and when it boots into Arch it sends me back to the grub menu...
But what happens when i switch distros again (i'm sure i will)? Will i be able to overcome this again? I rather have the certanty of the Windows bootloader at the forefront than grub or lilo.
Not only this, when i use the windows recovery CD it doesn't even detect the windows OS on the hard drive. It says something about not having a NFTS file system. I can't even use my backup-disks to restore windows, and i don't have an installation disk with a serial number. )The computer only came with a recovery/repair disk.)
I hope that you can see my problem, though its not urgent it is something i need fixed for the future.
Thanks
 

mqudsi

Mostly Harmless
Staff member
EasyBCD should ship with a copy of bcdedit.exe, so you should already have it.
C:\Program Files\NeoSmart Technologies\EasyBCD\bin\bcdedit.exe

Addendum:

You can use EasyBCD | Manage Bootloader | Reinstall Vista bootloader to put the Vista bootloader in front of the Linux one.
 
Last edited:

eredeath

New Member
Okay, um... this is probably very important that i forgot to mention and i appologize... I can't open EasyBCD, when i try it tells me that my registry is currupt and askes me to tell it the drive windows is on and i do, but it never loads...
 

Terry60

Knows where his towel is.
Staff member
If you can't see a Vista system to repair when you boot from the recovery disk, try disconnecting all the other HDDs temporarily, so that only the Vista HDD is visible when you boot.
 

eredeath

New Member
okay, so i tried to do the thing from the wiki... this is what i get:

Code:
The store import operation has failed.
The volume does not contain a recognized file system. 
Please make sure that all required file system drivers are loaded and that the volume is not corrupt.
this is what i get after the line
Code:
bcdedit.exe /import c:boot\bcd.temp
so what now?
 

mqudsi

Mostly Harmless
Staff member
You used the wrong line:
bcdedit.exe /import c:\boot\bcd.temp
is right.
 

eredeath

New Member
Sorry that was a typo in the post, not what i input into my computer.

Addendum:

I tried it again, to make sure i didn't make a typo... and sure enough i get the same error... any ideas? is there a way to re-install file system drivers?

Addendum:

Okay so this is what happened...
I booted up into Ubuntu (after re-installing grub) and ran gparted. I noticed a few things on my disk.
1. my windows partition was not bootable
2. i had 3mb of unallocated, unformatted space right next to my windows partition.

so i made my windows bootable and created another ext2 journaling file system out of the 3mb of unallocated space. Re-booted with my recovery disk( and for the first time, the disk recognized that windows exists on my machine!!). I ran the automatic repair and restarted. Booted into windows through grub and once into windows used EasyBCD to restore the windows MBR. Vuala! A working windows MBR :smile:

Thank you for your replies and help. :smile: :smile: :smile: !!!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
You're most welcome, eredeath; glad you got it working.

I wanted to especially thank you for detailing the solution that worked for you, I'll have to keep that in mind for the future - when bcdedit refuses to recognize the FS and automated repair won't see Windows, check out the partition layout. You learn something new every day!

:smile:
 

maus64

New Member
I also ran into the same problem when trying to execute the import command. Tried to rename bcd.temp but that didn't work. However, everything got solved when I did the windows system partition active with the diskpart tool, which can be run from the command promt. I think the mess occurred when I installed GRUB on the windows system partition. Thank you for the very good guide.
 
Top