Black screen on Windows 7 boot

Lupus

New Member
#1
Hello, I really need help with this issue.
I'm trying to fix my laptop, a Sony Vaio running Windows 7 Ultimate x32. When I power it on the Vaio logo appears and after it a black screen with a blinking underscore. No key works, except F2. I tried many ways, some described in this and other Forums, however nothing has worked so far.
I ran Windows 7 Recovery from a USB (thanks to Neosmart since the vendors want only our $$$ ) and there ran Startup Repair like a dozen times. Tried to rebuild bcd by running bootrec.exe with its commands (as described here: http://http://support.microsoft.com/kb/927392
more than a time, but no success. Ran Ubuntu Live CD , all the files and folders are in place, boot folder is were should be. Tried to build bcd using lilo and still no change.
All this happened after Ghost was interrupted during its boot running, because battery ran out and I forgot to plug it. Please, HELP !!!!
After three days I do not know anymore what to do. I appreciate every answer. Thank you.
 
#2
What messages did you get from the startup repair? Click Details and scroll down .

Did it find the operating system?

What message did running bootrec return?

I assume F2 is the key that takes you into Bios settings?

Did you see what was going on with diskpart commands ?
 

Lupus

New Member
#3
Startup Repair found the OS, after some tries, however always give me an error:

Problem event name: Startup repair offline
signature 01: 0.0.0.0
02: 6.1.7600.16385
03: unknown
04: -1
05: ExternalMedia
06: 1
07: OsVersionMismatch
08: 6.1.7600.2.0.0.256.1

As for Bootrec.exe:
/fixmbr and /fixboot - were successful. ScanOs - returned 0 Win. installations.
/Rebuildbcd - also 0 Win. installations.
These messages I got everytime I run it.
F2 indeed is Bios settings, but I can change only device order. In this moment first boot is optical drive, second external, and third hard drive. I changed so I could be able to boot from USB. I tried booting with hard drive first or default settings, still nothing.

Addendum:

Diskpart > detail disk returns 4 healthy volumes, however none is labeled as Boot or System. Also it says that it is not a boot disk?! According to startup repair the OS should be in volume 1.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
Did you have EasyBCD installed before this?
 

Lupus

New Member
#9
The commands below failed. The message says:
Failure when attempting to copy boot files.
bcdboot c:\windows /s c: and bcdboot c:\windows /l en-us

Then I tried bootsect /nt60 c: /force /mbr which wa successful.
" Successfully updated NTFS filesystem bootcode." and
"Successfully updated disk bootcode"
I think I should restart. Lets see.

Addendum:

Nothing happened ! :frowning: Same black screen.

Addendum:

Also I do not know if this is helpful, but I also cannot run either command:
sfc /scannow
This one says that there is a system repair pending and should restart, but I have restarted a dozen times by now.

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows
Here the message looks more strange.
Windows Resource Protection could not start the repair service.
And an window popped up with this message:

sfc.exe - bad image

x:\windows\temp\sss_9a3b5233dd0ccc01010000004802d001\wrpint.dll
is either not designed to run on Windows or it contains an error.
Try installing the program again using the original installation media
or contact your administrator or the software vendor for support
.
 
Last edited:
#10
Ghost was interrupted during its boot running
Were you restoring an image?

If so - it sounds like not everything restored and you have a bit of a mess there.

1. If you still have that ghost image - and bootable ghost program - try restoring the image again - using bootable ghost.

If you don't have bootable ghost - you can surely make it on another windows machine.


If that is not possible:

2. Do you have a recovery partition ?

You might be able to start it up by marking the recovery partition Active.

If sony recov program works - it will probably give you a couple of options.

One will be a complete return to factory condition - your data will be gone.

The other will be to "reinstall" windows , saving your data ( if there'es enough space. )

You need to check the wording carefully to make sure you select the option you want.
 
Last edited:
#11
I do not have any image on drive, tried the option on system recovery.
I retrieved my data using Ubuntu Live CD, now if there is any recovery partition, how do I make it active, since no key on keyboard respond to boot into? Also some say it might be hidden, then how do I find it?
By checking the dir. C:\boot I found a file called BCD_Backup.0001 which is dated at least a week before the problem started. Can this replace the actual BCD and make the OS bootable?
 
#12
I found a file called BCD_Backup.0001
You could try using that - but it sounds as if you have more issues than that will fix.

Recovery partition is probably hidden- it will be fairly small 6-10gb possibly - you may be able to mark it active from linux live cd - you probabaly have linux partition manager GParted on there.

I don't know if it will let you mark the recovery partition Active ( called Boot in linux , I believe ).

It may.

Otherwise, Partition Wizard free bootable cd is very good - worth getting a copy - that should be able to do it for you.

Try simply marking it Active - if you can't, then try changing the partition type to 0x07 - then mark it active.

Partition Wizard Bootable CD allows user to boot computer directly to manage partition.
 
Last edited:
#13
Sorry for the late reply. It was a hectic week. I tried everything I could.
- Replaced BCD with the backup one, nothing.
- Then tried both, first the GParted and then the Partition Wizard (which is really worth having, thanks, I added it on my Troubleshooting USB), they could not find any recovery partition.
Finally, at the end I installed Ubuntu 11.04 for good, and everything runs perfect. I should have done it long ago. If I weren't a gamer, would install it in my tower too. As conclusion, Windows is good only for gaming, nothing else.
Thank you to everyone for the advices. I really appreciate it. This became my favorite forum. Keep up the good work.