Black Screen with mouse pointer [No ang0]

#1
Hi, I have a bit of problem.
When I try to boot from my laptop internal hdd to windows 7 64bit home premium i eventually end up with a black screen with a mouse pointer.
I can move the mouse pointer around with the laptop touchpad.
The laptop will stay in that state until I power it off.

It appears as though windows 7 is being loaded but maybe not everything is being loaded.
I see the white rectangle box with green stripes as part of the boot process.
The black screen would normally appear with the mouse pointer just prior to loading my backdrop and the enter password box appearing.
Like I say, atm it only gets as far as the black screen with mouse pointer.

Trying to load into safe mode or any of the other f8 options has not worked for me, i end up at the same point, black screen with pointer.

I tried a windows 7 installer disk and going through the repair options.
After about 2 days i came to the conclusion that the regular install disk repair was not fixing my system.

I now have a usb stick i made by;
[h=1]Step-by-Step Guide to Making a Bootable EasyRE USB[/h]
Step-by-Step Guide to Making a Bootable EasyRE USB - EasyBCD - NeoSmart Technologies Wiki

i purchased the iso image from the link in that page.
i am using the latest 2.2 easybcd program.


When I boot from the usb stick i see this;
try (hd0,0): non-ms: skip
try (hd0,1): invalid or null
try (hd0,2): invalid or null
try (hd0,3): invalid or null
try (hd1,0): fat16: no ang0
try (hd1,1): ntfs5: no ang0
try (hd1,2): ext2:

and it just sits there with a underscore flashing on the line just after ext2:


I installed a new installation of windows 7 home premium on a different pc.
that pc used to have options to boot to windows 2008 r2 and windows xp.

I understood that I needed to make the usb easyre boot recovery? stick from a pc running windows 7.
i followed the steps from the above link, which includes i think saying yes to loading the bcd to the usb stick?

anyways this is where i am at; either boot to black screen with pointer when i try booting to windows 7 from the internal hdd or the list of try with the flashing underscore.

Can someone walk me through the steps i now need to take to repair the windows 7 on my internal hdd so that my laptop will boot back into my windows 7 64bit home premium without having to wipe it out by doing an install?

thank you for reading this far.