Blinking cursor trying to boot Fedora 12

#1
I'm setting up a triple boot as described here.

Only a couple differences for me. Instead of Windows 7 and XP, I installed Windows 7 64 bit and 32 bit (I have some recording hardware without 64 bit drivers). Instead of Fedora 11, I'm installing Fedora 12( x86_64). Also, I think in the instructions it says to use a regular install DVD, but I used the Destop (Live) CD.

So I went through all the steps outlined on that web page. I went through the EasyBCD part under "D. Install Fedora 11".

However, when I restart and select Fedora in the boot loader EasyBCD has been managing, I just get a black screen with a flashing/blinking underscore cursor in the top-left.

I am using EasyBCD 2.0 Beta Build 76.

I have tried removing and re-adding the Fedora entry. I have tried checking the "GRUB isn't installed..." box because that worked for this person but that doesn't work (I can give more details about what it does in this case if anyone thinks it would help).


My current EasyBCD settings:
Code:
There are a total of 3 entries listed in the bootloader.

Default: Windows 7 - 64 bit
Timeout: 20 seconds.
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7 - 64 bit
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Windows 7 - 32 bit
BCD ID: {0ff9381d-f010-11de-b8bc-b1fc12f9af1d}
Drive: E:\
Bootloader Path: \Windows\system32\winload.exe

Entry #3
Name: Fedora 12
BCD ID: {0ff9382f-f010-11de-b8bc-b1fc12f9af1d}
Drive: C:\
Bootloader Path: \NST\nst_linux.mbr
Thanks for any advice anyone has... seems like a great program in general, but I'm frustrated I can't get this part of it to work.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Leet, welcome to NST.
I believe Fedora 12 now uses grub2.
Try selecting that in the dropdown
(everything else "greys" because it's not needed - ignore it)
 
#3
I tried that as well. I've tried every permutation of checking boxes and stuff I can think of, so I changed it up.

I installed Fedora 11 in place of 12. My updated settings follow... "GRUB legacy" is type Linux>GRUB legacy with the "GRUB isn't installed..." box NOT checked, "GRUB legacy GRUBisntinstalled..." is the same but with that box checked. I also installed the NeoGrub bootloader for funsies.

------------------------
There are a total of 5 entries listed in the bootloader.

Default: Windows 7 - 64 bit
Timeout: 20 seconds.
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7 - 64 bit
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Windows 7 - 32 bit
BCD ID: {0ff9381d-f010-11de-b8bc-b1fc12f9af1d}
Drive: E:\
Bootloader Path: \Windows\system32\winload.exe

Entry #3
Name: Fedora - GRUB legacy
BCD ID: {0ff9383a-f010-11de-b8bc-b1fc12f9af1d}
Drive: C:\
Bootloader Path: \NST\nst_linux.mbr

Entry #4
Name: Fedora - GRUB legacy GRUBisntinstalledtoMBR
BCD ID: {0ff9383b-f010-11de-b8bc-b1fc12f9af1d}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

Entry #5
Name: NeoGrub Bootloader
BCD ID: {0ff9383c-f010-11de-b8bc-b1fc12f9af1d}
Drive: C:\
Bootloader Path: \NST\NeoGrub.mbr
------------------------

Here's what happens with each:

"GRUB legacy" - flashing cursor in top-left

"GRUB legacy GRUBisntinstalledtoMBR" gives me this message:
------------------------
Booting /boot/grub/menu.lst

Booting /grub/menu.lst

Booting /boot/grub.comf

find --set-root --ignore-floppies /boot/grub.conf

Error 15: File not found

Press any key to continue...
----------------

"NeoGrub Bootloader": I get a grub command prompt. Maybe this is working? I don't know anything about grub... but the impression I got was that I don't need to with this program. Maybe interestingly, when I use the command "root (hd0,1)" it prints "Filesystem type is ntfs... etc." but when I do "root (hd0,5)" (0,5 is the / partition I'm trying to boot to) it says "Partition table invalid or corrupt". I've reformatted partitions 4, 5 and 6 several times fyi.

Thanks for your help.. this seems like a weird problem.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
The "grub is not...." box is slightly confusingly named as many releases of Windows, Linux and EasyBCD have come and gone since it acquired that tag. It's due for a cosmetic overhaul with pop-up extra detail when Easy2 gets out of Beta.
For the moment the sticky thread explains when you should or shouldn't use it.
When you tick the box, EasyBCD installs Neogrub to effect a chain to grub on a separate HDD.
You don't need to install Neogrub.
Error 15 means you're looking in the wrong place.
Did you use "advanced" options and put grub in the Linux partition, or have you been creating multiple Linux partitions ?
With grub, it's just a case of telling the BCD where you've put it, and setting the flag appropriately.
With grub2 you don't even need to do that, as you can see here
 
#5
Gotcha... I figured I didn't need NeoGrub but I thought I'd try a few combos just in case and see what the results were.

I don't think Fedora 11 uses GRUB2 but I don't know how to find out. If it doesn't use GRUB2, then the first way I tried it with "GRUB (legacy)" should be the right way, right? The one that's giving me the flashing cursor?

Do you mean "advanced" options when setting up Fedora or the EasyBCD boot to Fedora? I have two Linux partitions, "/" on sda5 and a swap on sda6. I told the Fedora installer to install the bootloader on the first sector of the boot partition, which in the installer it identified as sda5.

Hopefully that makes my situation clearer? Any ideas? Thanks so much for your help, I appreciate it.

Addendum:

By the way, "NST\nst_linux.mbr" is empty... is that bad?
 
Last edited: