/boot/bcd error code 0xc0000225 Windows 7 Professional x64

#1
Hi there.
So this all started when I tried installing ubuntu 10.04 to a new 18gb partition. I already had a dual boot working when I installed Mac OS X on my computer, with chameleon on a flash drive. After I installed, windows would not boot, giving me the /boot/bcd error, but the error code then was 0xc000000e. I then tried using the repair disc for windows 7 64-bit from neosmart. It didn't work, saying it was not compatible. I thought it was just because I had an RTM version of Win7. I then tried using the disc I had the original install from (MSDNAA). Still didn't work. I later thought that the culprit was GPT. But after running Super Grub Disk a couple of times, through trial and error I was able to acutally use the repair install on the install cd (still doesn't work on the neosmart one). I also found that the error code changed when trying to boot back into Windows 7 (0xc0000225). It didn't recognize that there was a windows install, but it still gave me a message saying it encountered errors and that it would try to fix them. I clicked on details, and it said that my partition was Windows! I don't get it either. It also wouldn't let me boot the install cd! That was because the BCD was changed to backup for some reason. I just renamed it and went on my merry way. So I went on to startup repair. Didn't work again, and the details said that there wasn't a Windows OS on the partition, but said the operations still completed successfully. I then tried a bunch of different CMD commands, to no avail.
I'm all out of options, except for reformatting the entire drive, which would be a real PITA considering I like my hackintosh. Someone please come to my aid!

Thanks,
Para Vorheim.
 

JustinW

Super Moderator
Staff member
#2
Hi Para,

You can try our manual recovery steps for Windows 7 here. We don't support hackintosh setup.

If that fails a re-install seems likely. If you are unable to get into a OS on your drive grab a Ubuntu disc from here and rescue your files.
 
#3
already tried it

I already tried it, and it didn't work. It doesn't recognize that there is even a windows installation. Also, the OS X partition shouldn't be the culprit, because,
1. It doesn't have a bootloader, that's on a flash drive which I boot to.
2. It was working before that, it only messed up because of a ubuntu install.
The only reason I can generate for all this is because the partition is set up in the GPT style.

I'm trying out testdisk, to see if that does anything, but I doubt it will.

Thanks anyhow,
Para Vorheim

Addendum:

I got the install to work on an old 40gb IDE hard drive. Now, my question is can I rebuild the bcd on the other HDD using EasyBCD now that I have a working install, or is that not possible because it's on another hard drive?

Thanks,
Para Vorheim
 
Last edited:
#5
so there's still hope?

So there's a chance this can work?

YAY!

Addendum:

Okay, i selected the bcd from the non-working installation, but it says that access to bootmgr is denied. How should I go about getting access to the drive, without screwing anything up?

Addendum:

Okay, so I'm just going to back everything up from that partition (weird, only 13.4gb available...and then reinstall on a new partition.

Wish me luck!
 
Last edited:
#7
yeah

Yep, the copying of files is going decently fast, should be done within an hour, but anyways, I think the main culprit here is the GPT partition style. Windows 7 doesn't like it. I'm pretty sure the reason it even did that was because I made the partition inside Mac OS X. Also, installing Ubuntu in such a carefree manner is also a bad idea. Ah well, better luck next time haha.