Boot delay before selection

#1
I have Vista 64 as C:, Vista 32 as D: and XP as E:. My only problem is during boot, after the system has identified all the hard drives I get a flashing curser for about 30 seconds, then the EasyBCD screen comes up and I can proceed with no problem. I've used the Edit legacy function and only get Bootloader for XP. I set the time to 0, but that didn't seem to help at all. It's like the system is looking at an earlier loader that doesn't show up on the screen before going into EasyBCD. Any suggestions?
 

JustinW

Super Moderator
Staff member
#2
Hmm... in which order were the OSes installed? Fire up EasyBCD and recover the Vista bootloader if its booting straigtaway into XP. If thats the case, try adding entries for XP and your other instace of Vista. If you're still having problems, post a screenshot of disk management and your boot.ini file so we can see what is wrong with it.
 

Terry60

Knows where his towel is.
Staff member
#3
You mean the system completes POST, splashes the BIOS screen, then goes into a 30 second wait before displaying the Vista bootmgr menu ? (btw EasyBCD is a GUI for the Vista BCD - It's not the boot manager - it doesn't display a menu).
You shouldn't see another menu for XP after the Vista bootmgr. If you select XP from Vista's menu, it will chain to XP's NTLDR, which (having only one choice) shouldn't display a menu. If you're seeing one it must have errors in it which cause it to display.
 
#4
Terry60 has the sequence right. Once I make a selection from the menu everything proceeds normally. It's the delay before the menu comes up that's annoying.
For Kairozamorro, I've uninstalled and reinstalled these OSs so often (I had a bad hard drive in a RAID 1). Because Vista upgrade won't install unless there's another OS already in the partitian, I installed XP on C:, then installed Vista 64 twice, only registering it tne second time. I did the same with D:, installing Vista 32 twice, then installed XP once on E:. Finally I went back and reinstalled the Vista boot manager on C: and loaded EasyBCD. Once that was set up everything seemed to work fine except for that delay.
 
Last edited:

JustinW

Super Moderator
Staff member
#5
Ok... so ntldr is waiting 30 seconds before loading XP? Setting the timeout in EasyBCD won't help because that'll just modify Vista's bootloader. You need to edit the timeout value under [boot loader] in boot.ini to get ntldr to not delay when you want to boot XP.
 

Terry60

Knows where his towel is.
Staff member
#6
You can do a clean install to an empty HDD with an upgrade DVD. When it can't detect an OS to upgrade, it will ask for proof of ownership of a previous eligible OS, by asking you to temporarily insert the legacy OS installation CD. As soon as it reads it, it ejects and asks for the Vista DVD again, and continues with the install. You don't need to go to all the trouble of installing and overwriting the old OS.
As to the pre-Vista bootloader delay, I can only think that you might not have your Vista disk at the top of the queue in the BIOS boot sequence, so it's finding an MBR on another disk from all your multiple installs, and searching unsuccessfully, eventually ending up by trying the next disk in line, till it finds your C:\ disk.
If that's not the reason, I can't think of another at the moment.
 

JustinW

Super Moderator
Staff member
#7
Ok so its Vista. The default is 30 seconds unless you change it if there is more then one entry to choose from. Try re-settting the timeout for Vista's bootloader manually from the administrator command prompt...

bcdedit /set {bootmgr} timeout 5

The above command sets it to 5 seconds, plenty of time to select the other entries in case you didn't want to boot the default.
 

Terry60

Knows where his towel is.
Staff member
#8
Justin, you can set the timeout with EasyBCD of course, or
Control Panel/System/Advanced/Startup&Recovery, without needing to issue BCDedit commands, but flyboy's problem is a 30 sec wait before he even gets to the BCD choice.
 

JustinW

Super Moderator
Staff member
#9
I know that. I just mention the manual way as well (assuming that it has already been tried using the other more simpler methods). A re-installation of the OSes isn't the best route since its already been done.

By all means try the easiest fixes first and don't sweat the small stuff until you know its a more serious problem.
 
#10
After backing away from it for a while I finally got the problem solved. I had the CD as my first boot device. Once I put the hard drive first that delay went away. I don't know what happened to cause it in the first place since that's always been my sequence, but for some reason the system spent 30 seconds looking for a CD before kicking over to the hard drive and launching EasyBCD. Probably not a solution, but at least it's a workaround.
 

Terry60

Knows where his towel is.
Staff member
#11
It's normal to have CD before HDD in the boot sequence ( I have floppy/optical/HDD) and it doesn't cause a delay. Do you have access to another optical drive you can plug in temporarily ? Because it sounds a) like that one may have a problem, or possibly b) some other BIOS parameter is affecting the optical drive. A spare drive plugged in place should tell you which.