Boot entries lost repeatedly

Hi there. I have this strange situation. Dual-booting between Windows 7 and Windows 10. It had worked at some time. But I wasn't happy with my installation of windows 10, and reinstalled it. First thing that alarmed me: For some reason Windows 10 disregarded my Windows 7 installation even though I thought Windows does that by default. Yet Windows 7 is there (I got files from it)! So I installed EasyBCD, added the Menu entry for windows 7 and save this setup. Then I went to BCD deployment, write MBR. I double-checked in MSConfig. Both entries are there. Upon restarting, however, this whole setup is no longer active. Only Windows 10 is there... Went through the whole process again, even made Windows 7 the default OS. Same thing happened upon restarting. It boots straight into Windows 10 and the Windows 7 entry is lost. How can I regain access to Windows 7? Does it have to do with where the bootloader is? I thought EasyBCD detected that at install. This really puzzles me. It worked with my first install of Windows 10 with no problem.


Knows where his towel is.
Staff member
DON'T "write MBR"
Just add an entry.
Full stop.