boot.ini settings and file permissions issue

M

m12345

Guest
#1
startup error is:
NTOSKRNL.exe is missing or corrupt
(buts its not, its there, its fine)
I Know its a setting in that boot.ini file
which I can't even save due to the persmissions setting
which is odd

I have a dual boot
WINDOWS 7 on drive C (channel 0)

XP on drive G (channel 2)

different hard drives.
different OS
not sure if channel means disk #

my Windows 7 boot.ini file,:
the one that lives on C drive at the root of C....says:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP Professional x64 Edition" /FASTDETECT /NOEXECUTE=ALWAYSOFF

I changed the 2nd disk from 0 to 2 (or tried)
seems like they should definitely have different 'disk' settings since they are on different disks in fact

and tried to save the file
but it won't because its read-only
but when I check the file properties the read-only is NOT selected
what next?

kinda new to windows 7
any help is VERY much appreciated
LOVE easyBCD, very cool little program
 
Last edited by a moderator:
M

m12345

Guest
#3
thanks. one word UPDATE. ok, 2, LATEST BUILD. I just got the latest 2.x build, and it modified the boot.ini for me. works GREAT. I'm so happy.
 

mqudsi

Mostly Harmless
Staff member
#4
We're happy for you too :smile: