Boot manager failed to find OS loader

petterf

New Member
Hi There!

Problem with vista boot up, this is the error that the vista recovery start reparation says (from recovery partition) and oh yeah, I automatically get to the recovery thing:
Root cause found:
--------------------------------
Boot manager failed to find OS loader.

Repair action: File repair
Result: Failed. Error code = 0x2
Time taken = 156 ms

Repair action: Boot configuration data store repair
Result: Failed. Error code = 0x2
Time taken = 0 ms

I have run chkdsk with /f and /r, there were errors, but now there are none.
Bootrec /scanos or /rebuildbcd gives zero identified windows installs, strange considering the start repair thing found it, but could not fix it.
i have run /fixmbr and /fixboot also, and these succeded, but still the same error.

Anyways - the reason for this to occur in the first place is a little bit embarrassing, a friend of mine asked if I could help out, he didn't know what was wrong, probably some virus, there were several programs he could not start - he gave me his computer, I immediately took out the harddrive and put it in a usb dock connected to my computer and first ran chkdsk (some errors) and then ran panda antivirus(found some viruses), I then though that these things was his problem - I though I was done. I was in no rush, so I figured I'll run a defrag and did so. When I after that put the hdd back in the computer I realised that he hadn't shut down his computer, but put it in hibernate! Windows loaded the files and I was at the desktop, but almost anywhere I clicked there were of errors telling me "run chkdsk, file error blablabla" got it to start shutting down, but it couldn't finish and I hit the power button.
The embarrissing part is of course that I didn't check that the computer wasn't in hibernation. This has never happened to me, no one has ever given me their computer for me to fix - and the computer was in hibernation.

Anyways, I then took out disk again and ran chkdsk which came up with _tons_ of errors.
And yeah. Now I'm stuck.

Thankfull for any help - I've searched the web for hours and hours, but found nothing that could help me :frowning:
 
Last edited:

petterf

New Member
Hi Mahmoud!

I seem to be getting somewhere, I now created a new bcdstore - And now I get this error:
FIle: \Windows\System32\Winload.exe
Status: 0xc000000f
info: The selected entry could not be loaded because the application is missing or corrupt.

LaL. should I just try and place a new winload.exe from my working vista into this computer?
And when I run startup repair, now from CD(the comp doesn't start auto from recovery partition any longer), it says the same thing - so one part of the error is gone....it now has a working bcd ....

Thx for helping me out! :smile:

Just a note though:
I did not use bootsect, but only bootrec /fixboot instead, since I do not have bootsect. Does it matter? And bootrec failed to /rebuildbcd - I did it manually according to instructions
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Usually that means that the drive you put for the entry is incorrect.
 

petterf

New Member
This is really funny, it was actually - not there. so I copied over a new one - then it was missing something else, and the windows vista repair CD said it couldn't fix that either because Windows Resource Protection data was corrupt or missing. So I copied over that file too, and now there was another missing file---
I started to copy in everything that goes into system32 catalog - and alot of files were missing.

And now it loads alot of drivers before giving me a bluescreen saying I should disconnect new hardware, I might have a virus, I should run chkdsk and whatever.
And still Startup Repair tells me it can not fix anything since WRP Repair is corrupt...

I though I would give the recovery partitions repair thingy a second chance, so I reinstated the old bcd, and now it seems like that one is working again...it gave the option whether to start windows normally or launch startup repair :tongueout:
And it gives me something like unspecified changes in the systemconfiguration(hardware configuration) is causing the problems...

Addendum:

Gah. If it doesn't give me something more specific, then I might have to do a complete system restore after all :frowning:

Unless someone has a really good idea about what to do :wink:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
Looks like you lost your system files due to drive corruption. You're now in between a rock and a hard place - if you have a backup, this is the time to use it :smile:
 

petterf

New Member
Yeah. The only question is, was it caused by my actions - could it be like that? Or was this the case even before my actions were taken. I will anyway check so that the future computers that I intend to fix is shutdown completely and not in this freakin hibernation, which sucks anyway :tongueout:
 
Top