Boot Menu Can Activate Centos but not OpenSUSE

I just purchased EasyBCD 2.3 to make it easy to create a dual-boot configuration (Win 7 and a Linux distribution) on an MBR-format hard drive. I tried two different Linux dintros (Centos 7 and OpenSUSE LEAP). (I installed only one at a time, using the same unformatted hard drive space.)

With each install, a boot code was added to the Master Boot Record of the C: drive, pointing to Grub2 in the Linux system. This created a Linux-based boot menu on start-up. I could have just used this Linux-based boot menu. However, I really wanted a dual-boot menu on the Windows side. So I tried to create one using EasyBCD.

EasyBCD could automatically locate the Centos OS, and it created a working menu option.

EasyBCD also created a menu option for OpenSUSE, but that option did not work on startup. Somehow, GRUB2 was being activated, but the boot process stalled, leaving me at a command line somewhere in the GRUB2 bootloader application.

I tried installing OpenSUSE again, in a different way. I installed the boot loader not on the MBR record, but on the Linux partition. Once again, I tried to make EasyBCD find Linux. It created a boot menu option, but that option did not work on startup. It left me at a command line on the C: drive.

I am wondering, why could EasyBCD not activate OpenSUSE?

Thanks for any help you can give me.