Boot menu item doesn't show up on EasyBCD

A friend of mine set up this laptop for me (running Vista - legal license) but it looks like he may have had a XP Pro install CD in the drive at some point in time, because there is a "Windows XP Professional Setup" option in the boot menu. This wouldn't be too bad, except that it is the default option.

Since this is Vista, there is no boot.ini file, so I have done what I could with the System startup options (set to use Vista as the default) - but no luck. I tried using bcdedit directly and then found your software (very nice btw).

However, the only boot options EasyBCD knows about is the Vista option, which is also the default. Yet every reboot puts me into an XP Pro install. I tried some of the options (e.g. writing a new MBR file), recreating boot files (it said the files were already there and didn't do anything).

Is this a bug in EasyBCD or is it just my system? And, is there any way to fix my problem?

Thanks so much!!
Found alternative solution


Thanks much for the response. I ran the Vista repair, but it could not find any problems to repair and the problem remained unsolved. But then using EasyBCD, I found Tools->Edit Legacy Entries. Which brought up my boot.ini file (which I could not find on my C drive) - and the offending entry for Windows XP Professional Setup was easily removed. Everything is fine now and your quick response merited a contribution to your December fund.

Thanks much!


Mostly Harmless
Staff member
That's great news :smile:

Thanks for the contribution as well, much appreciated.