Boot problem

I'm running windows 7 and I installed Linux to HD0,7or dev/sda8. I installed the grub in that partition and when I configure Easybcd and iReboot it boots into a black screen with a flashing cursor in the top left corner. Nothing happens.

The partition is on the same drive, grub is legacy, and I don't check off the mbr/bootsector option. I leave it blank like the instructions say. I don't know what to do.

timeout 10
color black/cyan yellow/cyan
gfxmenu (hd0,7)/boot/gfxmenu
default 0

title linux
kernel (hd0,7)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=6368746f-2074-616b-6f65-207575696400 splash=silent vga=788
initrd (hd0,7)/boot/initrd.img

title linux-nonfb
kernel (hd0,7)/boot/vmlinuz BOOT_IMAGE=linux-nonfb root=UUID=6368746f-2074-616b-6f65-207575696400
initrd (hd0,7)/boot/initrd.img

title failsafe
kernel (hd0,7)/boot/vmlinuz BOOT_IMAGE=failsafe root=UUID=6368746f-2074-616b-6f65-207575696400 failsafe
initrd (hd0,7)/boot/initrd.img

title windows
root (hd0,0)
chainloader +1
Can someone please help me with this problem? I ve been posting this problem for awhile now, I check it twice a day and nothing happens. Is there something wrong with my post or is there no fix for my problem? It would be nice to know. Thanks


Knows where his towel is.
Staff member
Which Linux ?
btw iReboot is a Windows app. You can't use it in linux, and it needs to be installed on all OSs in a Windows multi-boot to function as designed.
Are you using iReboot or the bootmgr menu in this failed boot ?
Last edited:
Yes I'm using Windows 7, Easybcd and iReboot. The Linux I'm trying to load is PCLinuxOS and it uses grub 1 legacy. The rest is all there in my initial post. Thanks for replying.


Knows where his towel is.
Staff member
What's failing ? An attempt to boot Linux from the W7 boot menu, or an attempt to boot into Linux from W7 using iReboot ?
As I said, the latter course is not appropriate for a dual-boot except where both OSs are Windows.
Problem solved

Got it! Yes the problem was not being able to boot into PCLinux from Windows using iRebroot but that I had successfully done so using Opensuse.

I'm still learning this but it occurred to me that I was using the extended partition, however, Opensuse has no problems booting up from there. I was never able to boot PCLinux from its 10GB partition next to Opensuse. I decided to create another partition from a large primary one and so I created a 10 GB partition and did the PCLinux installation again.

I went back to Windows, and reviewed the configuration in EasyBCD and then rebooted the computer using iReboot and low and behold it worked. PCLinux boots up nicely now using iReboot. Opensuse boots up from its location in the extended partition also with iReboot. Problem now solved!

It appears I've managed to snatch defeat from the jaws of victory.
PClinux now boots nicely with iReboot from a primary partition. I could never load it from the logical partition in the Windows 7 extended partition.

That being said my Opensuse always booted from its logical in the extended. Also with iReboot etc. Not anymore, I can only boot PCLOS. Is it not possible to have two different Linux builds in EasyBCD? I can't seem to have both it's either one or the other. I don't know where I went astray. Help!