Booting error in Vista

#1
I have an Acer Aspire 5920G laptop and Vista (only) installed as OS. I was cleaning my laptop (turned off) and accidentally pressed the shortcut button for launching Acer Arcade Deluxe. It suddenly boots up then install the deluxe, thinking that since it is from acer it will not cause any problem later so i let the installation to finish. After the installation i was able to use the deluxe for sometime then i decided to exit from it and return to Vista. When i click on the exit button the Microsoft Windows XP logo appeared together with the hibernating progress bar. When i tried to boot to Vista an error message appear containing:

File: \Boot\BCD

Status: 0x000000f

I believed that the installation of Acer arcade deluxe (not inside Vista) used XP to install it in my laptop and at the same time overwirtes the boot configuration for Vista. I've tried ALL steps mentioned here http://neosmart.net/blog/2008/windows-vista-recovery-disc-download/ and here http://support.microsoft.com/kb/223188/ but to no avail nothing happened.

Inside the Recovery disc, i can only use the command prompt and the other features (like system restore, complete pc recovery) always results in an error.

Everytime i go to command prompt the default directory is:
X:\sources> (what's this? is this a hidden partition?)

i can change to E: (DVD) but can't to C: (System) and D: (my files).

I've just tried this one also http://support.microsoft.com/kb/927391#top but still nothing.

Can't fix with acer recovery also... D2D mismatch error messages appears.

Can anyone please save me from this one.

Thank you very much in advance.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi Albert, welcome to NST.
Boot the Vista recovery disk, select "repair my computer" then "repair startup".
Do this as many times (2 or 3 probably) as is necessary to get Vista booting unaided again.
 
#3
Terry, thank you very much for the response. After i click the "Repair your computer" a window appear for System recovery options which let me select the OS i want to repair, but i can't see my OS and tried to browse for any driver for my hard disks and can't find anything also. So i click "Next" and the list of recovery tools appear. I can see also in the window saying "Operating system: Unknown on (Unknown) Local Disk". As of now i'm repeating to select "Startup Repair" but the same error message keeps appearing. Please find below the problem details:

Problem signature:
Problem Event Name: StartupRepairV2
Problem Signature 01: ExternalMedia
Problem Signature 02: 6.0.6001.18000.0.0.0.0
Problem Signature 03: 0
Problem Signature 04: 65537
Problem Signature 05: unknown
Problem Signature 06: CorruptVolume (hope this is not right :scared:smile:
Problem Signature 07: 0
Problem Signature 08: 1
Problem Signature 09: Chkdsk
Problem Signature 10: 31
OS Version: 6.0.6001.2.1.0.256.1
Locale ID: 1022


Diagnosis and repair details:

Statup Repair diagnosis and repair log
----------------------------
Number of repair attempts: 1

Session details
----------------------------
System Disk = \Device\Harddisk0
Windows directory =
AutoChk Run = 0
Number of root causes = 1

Test Performed:
----------------------------
Name: Check for updates
Result: Completed successfully. Error code = 0x0
Time taken = 31 ms

Test Performed:
----------------------------
Name: System disk test
Result: Completed successfully. Error code = 0x0
Time taken = 16 ms

Test Performed:
----------------------------
Name: Disk failure diagnosis
Result: Comopleted successfully. Error code = 0x0
Time taken = 359 ms

Test Performed:
----------------------------
Name: Disk metadata test
Result: Completed successfully. Error code = 0x0
Time taken = 748 ms

Root cause found:
----------------------------
System volume on disk is corrupt.

Rapair action: File system repair (chkdsk)
Result: failed. Error code = 0x1f
Time taken = 0 ms

----------------------------
----------------------------

Hope this details help you to analyze whats happening on my laptop. Thank you very much.
 

Terry60

Knows where his towel is.
Staff member
#4
This inability to find the system to repair automatically seems to be happening more and more frequently on these boards.
If the recovery disk won't do it for you (the simple option), try the manual recovery using EasyBCD detailed in the wiki
 
#5
Tried all steps also mentioned here but can't still fix it. http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD

For Step Three:

bootrec.exe /fixmbr

*The operatoin completed successfully.


E:\boot\bootsect.exe /nt60 all /force

*'E:\boot\bootsect.exe' is not recognized as an internal or external command, operable program or batch file.

*Directory of E:\boot
[ . ] [ . . ] bootfix.bin bcd boot.sdi

*No bootsect.exe under this directory.


del C:\boot\bcd

*The file or directory is corrupted and unreadable.


bootrec.exe /rebuildbcd

*Successfully scanned windows installation.
Total identified windows installation: 0
The file or directory is corrupted and unreadable.

I didn't continue on step four since everytime i include the C: directory "The file or directory is corrupted and unreadable." always appear.

Is it advisable to install XP, then from there install EasyBCD then configure the Vista BootLoader from there?

Cheers!
 

Terry60

Knows where his towel is.
Staff member
#6
Afterthought - Is your Vista partition marked as "active" ?
If not, try making it active from the recovery console as detailed by Guru , and see if the auto repair locates your system.

ADDENDUM

Sorry this post crossed with your latest and Guru's reply Albert, and doesn't refer to what you're currently discussing.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
"The file or directory is corrupted and unreadable."

This would seem to indicate you have a corrupt disk. Try this:

Code:
chkdsk C: /f
 
#8
Terry I was able to activate the partition that the system files are on. I just have to changed some details on the post by Guru since C: is no 2 partition for my laptop. and have to put disk 0 also.

now i'm doing chkdsk c: /f and lots of replacing and invalid security id being fixed right now. hope this solves my problem.

get back to you after this one completes. thank you again

Addendum:

Terry and Guru both of you are a star mate. Now i'm jst checking all the errors and what cause the problem. Cheers!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#9
Hey Albert, glad to be of help. Hope it fixed your problem!
 
#10
Guru

I thougth my problem was solved but everytime i boot my laptop now it always got stock in a blank screen with my mouse pointer visible (i can move the pointer as well). I let it run all night also jsut in case it continue to load vista but when i woke up, same blank screen with my mouse pointer.

I tried using step four mentioned here http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD.
All commands were successful except for this one x:\boot\bootsect.exe /nt60 all /force.
Changed drive letter to E: (dvd drive), tried X: (hidden part), C: (system) and D: (my files) but same error message appears mentioning that it is not recognized as an internal or external command operable program or batch file.

Tried also the reply by kairozamorro here http://neosmart.net/forums/showthread.php?t=2710 but it does nothing also.

Please i need your help again. Cheers

Addendum:

Terry can you please help me with this one... i can't contnue booting in vista. only black screen and the mouse pointer is visible. I can move the pointer though. Everytime i tried to start with all types of safe mode it always stop in "crcdsk.sys" drive. please help me.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#11
From what I've seen on here before, the crcdisk hang is probably another symptom of a corrupted HDD. (You're getting past the boot stage)
I think you ought to be downloading yourself a bootable Linux live CD, and copying all your personal data files to somewhere safe, or you can use the dir and xcopy commands from the recovery console to identify and save them.
Then do a nice clean factory reset of your PC to reinstall Vista.
 
#12
hi

@albert
Hi i have an acer aspire 4736 laptop and just recently it also started doing the same as in ur case:frowning:. I searched the net and found this particular forum where there was some action taken to solve it. So i want to know if the problem which u faced is solved?If yes then how did u go about it?
Any help from you or the moderators would be greatly appreciated.
Thx