Booting FC6 without GRUB installed


I'm trying to get Vista to co-exist with Fedora Core 6. I have 2 physical HDs: one with vista RC1, the other with FC6. When I installed FC6, i opted not to install GRUB as it would only install to my vista HD (which is bad :smile:). So, now I'm trying to get NeoGRUB to load FC6. When i select it from the Vista bootloader, i just get sent back to the same vista bootloader. I'm using ext3 on my FC6 install as well. I've also tried using hd1 and hd2 in the menu.lst file. The following is my menu.lst config (it's basically a guess as I didn't install GRUB in the first place):


title Fedora Core (2.6.18-1.2798.fc6)
root (hd1,0)
kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00
initrd /initrd-2.6.18-1.2798.fc6.img

Does anyone have any suggestions on how to get FC6 to boot?

I tried to install GRUB on the 2nd HD and use the Linux option (vs. NeoGRUB) in EasyBCD. Still no dice. :frowning:
For the Linux option, i used Disk 1, Partition 1 since its the 2nd HD and 1st partition.

And as the NeoSmart Wiki is down, I have no other source of information.

Any suggestions?
Hi neflyte, welcome to NST!

You have to install it a *partition* and not the MBR of your second drive, that's probably why your second step didn't work.

However, try specifying your
line in the more conventional /dev/hdxy format, that might help.

Good luck.
Interestingly enough, if I set my PC to boot from the 2nd HD, GRUB loads but fails because it doesn't recognize the filesystem type. I'll try setting root=/dev/hdb1 and reinstalling grub there. Thanks!
It didn't work. :frowning:

I've moved on to simply changing the boot order in the BIOS. I'd really like to know why this doesn't work, though. Is there any kind of verbose messages or debugging I can make NeoGRUB display when it loads?
You could try deleting the NeoGrub config file. That'll give you a full GRUB prompt screen... Or it should, anyway.