Booting non-windows partitions.. PLEASE HELP!!

#1
When I first installed easybcd it worked fantastic and I was able to boot XP Vista + Mac OS X with no problems. I had a bit of a mishap installing debian and stuffed up my MBR but after alot of fiddling I managed to recover things and get them working again. Unfortunately for some reason I can no longer boot to OS X and I also can't get a new install of debian to boot (grub is installed to the partition that debian is using.) In both cases the error I get is about /NST/something.mbr on the C: drive. I don't have this folder so I'm wondering do I need it and have I deleted it by mistake.

Ideally I would like to be able to boot all 4 OSes from the Vista boot menu.

Any help would be greatly appreciated

Thanks in advance
tooner
 

mqudsi

Mostly Harmless
Staff member
#2
Hi tooner, welcome to NeoSmart Technologies.

Delete the OS X and Linux entries in EasyBCD, then re-create the OS X entry - OS X should work immediately.
As for Linux, you have to either install GRUB to the *bootsector* of a partition, or use NeoGrub instead - if you choose to use NeoGrub you will have to configure the GRUB boot menu for NeoGrub though too.

If you need help doing any of that just ask away, but it's not too difficult, and a Google search should set you going.

Good luck!

(PS: I'm glad EasyBCD worked great for you at first - hopefully we'll have you back up and running in no time! Tell others about EasyBCD too, they'll thank you for it!!)
 
#3
Thank you for responding so quickly. Unfortunately I was clearing up my XP partition before I created a ghost image and I manually deleted the /NST/ dir not realising what it was for and banished it from my recycle bin. I have tried readding entries but unfortunately the /NST/ dir is not recreated. When I manually add that dir myself the .mbr files that are normally created when a new entry is made do not appear. I have tried reinstalling a few times but with no luck. Is there any magic tricks I can use to restore this dir and these files? :smile:

Thanks alot
tooner

PS Don't worry I have been singing its praises!
 

mqudsi

Mostly Harmless
Staff member
#4
well, did you try to uninstall then reinstall EasyBCD?
What version are you using as well?