Booting to Ubuntu only gives grub prompt

#1
I'm trying to set up a W7 Home Premium 64-bit/Ubuntu 11.04 64-bit dual boot on my Lenovo x120e. I had it partially working before (could boot into Ubuntu through the grub menu, but not W7), but then I had to send my laptop back for repair when the motherboard gave out. Before the motherboard failed, I actually borked the MBR trying to get W7 to load, but that's another story.

When I received the repaired laptop back, it booted normally to W7, and I saw that the W7 partition was still the smaller size I had set up when I resized it during the previous installation attempts. I then tried several times to install Ubuntu to the free space. One issue is that Ubuntu installation on this laptop seems to require use of the alternate installer, as the standard graphical installer for Ubuntu inevitably fails during installation. (This problem and solution has been noted by other x120e owners on other forums.) I would also prefer to have a setup with separate /, /home and swap partitions, so I have been choosing manual partitioning during my installation attempts. After the first new installation attempt, I got the Windows Boot Manager on startup, with no Ubuntu entry. Strangely, I did not see any grub boot menu at startup as described in the NeoSmart wiki. I then modified the MBR by adding an Ubuntu entry via Easy BCD. I could then see an Ubuntu entry, but choosing it just leads me to a grub prompt. I have tried reinstalling several times, and I get the same result. I saw on these forums that someone thought ext3 formatting was the solution, but this did not help. Plus, I was able to boot into Ubuntu on an ext4 partition before the repair I mentioned.

So, how do I install a W7/Ubuntu dual boot on this machine? As I said, the wiki is of limited help, as I need to use the alternate installer, and I would like to have the manual partition setup I described above. At this point I am not tied to using an Easy BCD solution (I'm ok using the grub menu at boot, just not a grub prompt). I just want it to work. Thanks.
 

Terry60

Knows where his towel is.
Staff member
#2
Did you select grub2 from the dropdown when you added 11.04 to the W7 BCD ?
 

Terry60

Knows where his towel is.
Staff member
#5
#6
Yes Im aware of the Wiki. However the Wiki is outdated. Im using Ubuntu 11.04 and wiki shows screens for 10.04. Screens different for 11.04. And screens for EasyBCD in wiki are not the same as EasyBCD 2.1.0.146 of wich Im using. I do not see in "Setup Bootloader" page:

Adding Ubuntu to the Windows Bootloader

Step Three
Go to the "Setup Bootloader" page in EasyBCD, and select "Install the Windows Vista/7 Bootloader to the MBR" then press "Write MBR":

I do not see that page.

I can load all three os's (WIN XP, WIN7 and Ubuntu) from Ubuntu start menu but prefer the EasyBCD menu. So step three above I believe to be important for this to happen. Is it the install of neogrub I need perhaps?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#7
If you look at the illustration, you'll see it's the penultimate page.
It changed its name in 2.1 to "BCD deployment", but it's still the same tab (and there aren't that many to look through to find the "install ..boootloader" options)
I've updated the wiki now.
 

mqudsi

Mostly Harmless
Staff member
#8
Thanks, Terry.
 

Terry60

Knows where his towel is.
Staff member
#9
I didn't change the image though CG, if you want to bring that into line with 2.1.
 
#11
I swear I used to be able to do this, easily. Now I have a nice new system (Sandy Bridge, UEFI and all ...) and as a result I'm unable to chainload Ubuntu's GRUB 2 from Windows 7's NTLDR via EasyBCD, all I'm getting is a grub promt.

I'm trying to boot into a fresh install of Ubuntu 11.10 via EasyBCD 2.1.0.152.

1. Does the current NeoGrub/GRUB4DOS build that comes with EasyBCD 2.1.0.152 support ext4?
I could have sworn I was able to chainload GRUB2 + ext4 installs of Ubuntu before but I can't for the life find a definite answer to this question.
If it doesn't, that would probably already answer my question and I'll have to find a different way ...

2. How up to date is the Wiki page when it comes to 11.10?
On first sight Bug #614309 mentioned on the page appears to be resolved in Oneiric. At least I had no problem installing GRUB2 either into the MBR of sdc or into the Ubuntu partition created by the installer. However, I'm unable to chainload either one. So far I have avoided installing GRUB2 into sda's MBR but I guess that will be my next step (I may not have another choice but to chainload NTLDR from GRUB instead of the other way around).


This is my machine's current setup:

sda with Windows 7 installation
sdb with a huge NTFS partition for programs and a second one for Windows 8 preview (this shouldn't have changed NTLDR significantly, but even if it did, it has long since been repaired via EasyBCD running from Windows 7).
sdc
sdc1 - NTFS, storage
sdc2 - Linux swap
sdc3 - exta4, Ubuntu 11.10 64bit
+ some external drives

So far I tried installing GRUB2 into sdc and sdc3, neither allowed me to boot into Oneiric - even when changing the HDD's boot order and booting directly from what is normally sdc/(hd2,2) (this appears to confuse GRUB2 too much, it also just gave me its prompt and even after trying to read up on it I'm simply too stupid to do anything really useful on it).

I tried to create several boot menu options via EasyBCD each time, first and foremost GRUB2 ... but out of desperation also legacy GRUB with and without autodetect, NeoGrub etc.
The GRUB2 entry only gives me the boot promt, all the other have problems finding any boot files (which is somewhat understandable).

Sorry for being so confusing and asking so many stupid questions, but I could use some help ...
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#12
Considering that Ubuntu 11.10 was only released a few days ago and the wiki states that it was last updated 9/25/2011, I highly doubt that the latest version was taken into consideration when the Wiki was written or if EasyBCD has even been tested with it to date.
 
#13
Considering that Ubuntu 11.10 was only released a few days ago and the wiki states that it was last updated 9/25/2011, I highly doubt that the latest version was taken into consideration when the Wiki was written or if EasyBCD has even been tested with it to date.
Well, at that point Onieric was in final testing, the final beta build before its official release had just been published and I was unable to reproduce the bug mentioned in the article in said beta as well ... so the question isn't as ridiculous as it may sound to you for someone interested in Ubuntu's development. But you're right, maybe the phrasing was a bit off.

Either way, I'm still eagerly awaiting a helpful reply, maybe by someone in the same situation who resolved it already or someone more skilled in the use of GRUB2 and NTLDR?

Thanks for your help in advance!
 
#14
Alright, I followed the instructions to the best of my abilities and installed GRUB in sda this time ... it still didn't work. I'm having the exact same problem as the op and no idea how to fix it. Installed GRUB2 into sda but GRUB still won't launch before NTLDR does and the EasyBCD entry for GRUB2 only gives me the grub prompt ... I'm at my wits end and would really appreciate some help from someone who managed to resolve this somehow.