Bootloader Path for Multi-boot System

celmo

New Member
#1
I just restored an image of the initial Windows 7 install and tried to add it to the boot menu but am unable to boot to that install of W7. However, the path it set doesn't refer to a drive/partion the way it does in XP so I am not sure how to resolve. Any assistance would be greatly appreciated.

View settings:
There are a total of 3 entries listed in the bootloader.

Default: {current}
Timeout: 30 seconds
EasyBCD Boot Device: D:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Microsoft Windows XP
BCD ID: {93c6122e-b5ea-11df-91ad-d08c30ca3d79}
Drive: D:\
Bootloader Path: \NST\ntldr

Entry #3
Name: Microsoft Windows 7 Initial
BCD ID: {default}
Drive: N:\
Bootloader Path: \Windows\system32\winload.exe
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
Change your BIOS boot sequence to put the W7 HDD with the "system reserved" partition first.
Reboot
Add the new W7 entry again.
 

celmo

New Member
#3
Terry - thanks but 1) I don't have that kind of control in BIOS. and 2) because I didn't label my partitions, I see that it might be confusing. I have now labeled each of the 2 W7 partitions (see attached). I am able to boot to and use the W7Primary but when I try to load the W7Initial, it reverts to the W7Primary since their paths are the same.

Oddly enough, W7Primary is Drive 0 in the BIOS.

Thanks,
Celmo
 

Attachments

Terry60

Knows where his towel is.
Staff member
#4
If you can't do it in the BIOS (are you using Acer ?), then swap the HDD cables so that you're booting from the correct HDD.
 

Terry60

Knows where his towel is.
Staff member
#6
You can see that XP is disk 0, which would indicate that it's set as the boot HDD in the BIOS (subject to known W7 Disk Management bugs).
Try swapping the cables between XP and W7.
Alternatively, the BIOS will generally swap the boot disk allocated if it has no choice. ie disconnect all except W7, boot it, then reconnect everything else and boot again.
That should have reset the boot sequence.
(I boot from SATA channel 4. The physical connection and the logical boot sequence aren't necessarily related)
 

celmo

New Member
#7
Resolved

I turned off all but the drive I wanted to boot to and then ran a repair. Oddly enough, I can't boot to it with the other drives turned off, but once I turned them all back on, I am now able to select the W7Initial and boot into it. Also odd to me is that changing my desktop preferences in one W7 installation affects the other so that they remain in sync. Otherwise this is resolved.

Thanks for you help.
 

Terry60

Knows where his towel is.
Staff member
#8
Had you changed the location of C:\Users\Yourname\Desktop to a different HDD before you cloned the second copy ?
If so both will be using the same files, from the same location.
 

Terry60

Knows where his towel is.
Staff member
#10
Weird !!