bootmgr is missing (probably not the usual issue)

#1
I've used easybcd to boot vista and ubuntu for well over a year now. This has worked flawlessly at all times.

I've now installed Windows 7, sorted out the bootloader in the same way (like so):

Boot from ubuntu cd and copy the lines from menu.lst on my ubuntu installation onto the windows partition.
Boot from the windows dvd, and run a startup repair.
Boot into windows, run easybcd, install neogrub, then paste the lines I copied from menu.lst, into the neogrub configuration file
Save the configuration, then reboot.

This has always worked on Vista

I tried the same with windows 7 last night. I got an error after installing neogrub and configuring it.

I read up on it, and saw that I needed easybcd 2.0 to get it working with windows 7.

I came here, registered, downloaded and installed easybcd 2.0, configured the bootloader in the same way as mentioned above. Everything then worked.

However, one of the options I have in the neogrub bootloader configuration is what I named 'Exit Grub'

All this does, is load the windows bootloader. On selecting this when rebooting, I got an error....I completely forget what now, but on rebooting again, I got 'bootmgr is missing'.

I then tried booting from the windows 7 dvd, and running a startup repair. Didn't work. Tried the other ways: bootrec /fixboot and bootrec /fixmbr. Also did not work.

I ended up restoring a system image that I took yesterday to get windows 7 to boot again.

Does anyone know why i'm getting this problem?

My ubuntu boot configuration is as follows:

oops....will edit this in a sec....need to get the boot config file from ubuntu.

Edit:

title Ubuntu 8.04.4 LTS, kernel 2.6.24-16-generic
root (hd1,4)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=603434d8-55d6-44f5-897d-5744a7aa65fe ro splash
initrd /boot/initrd.img-2.6.24-16-generic
quiet
title
Ubuntu 8.04.4 LTS, kernel 2.6.24-16-generic (recovery mode)
lock
root (hd1,4)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=603434d8-55d6-44f5-897d-5744a7aa65fe ro single
initrd /boot/initrd.img-2.6.24-16-generic
title
Ubuntu 8.04.4 LTS, memtest86+
root (hd1,4)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST
# This is a divider, added to separate the menu items below from the Debian
# ones.

title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title Windows Vista/Longhorn (loader)
root (hd0,1)
savedefault
makeactive
chainloader +1
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Where are the W7 and Ubuntu systems in relation to each other, compared to Vista/Ubuntu ?
I assume that Vista and Linux are on different HDDs if you are using Neogrub.
Windows and Linux on different HDDs require the "grub isn't .........." box to be ticked (which bridges the HDDs with Neogrub). Windows and Linux on the same HDD don't need Neogrub. Just add a Linux entry and don't tick the box.
 
#3
I no longer have Vista on here....that entry was a result of copying my boot configuration from ubuntu, which hasn't been updated as it isn't used (The ubuntu boot configuration is stored on the windows drive using neogrub).

From what I know about Vista and win7 though, the boot configuration is identical to Vista (although I may be wrong).

Windows 7 is on my internal drive, and Ubuntu is on my External drive.

I think I left the 'neogrub isn't......' box unticked when I tried, so that may be the problem.

I'll try it with it ticked once i've done a new system image backup tommorow.

Thanks for the help.
 
#4
However, one of the options I have in the neogrub bootloader configuration is what I named 'Exit Grub'

All this does, is load the windows bootloader. On selecting this when rebooting, I got an error....I completely forget what now, but on rebooting again, I got 'bootmgr is missing'.
According to your neogrub menu.lst configuration, which you posted, there is no such boot option called "Exit Grub"...
 
#5
According to your neogrub menu.lst configuration, which you posted, there is no such boot option called "Exit Grub"...
The 'Exit Grub' option I mentioned, is basically the 'Windows Vista/Longhorn (loader)' option that is in the configuration I posted above, just renamed to 'Exit Grub' (all it does is load the Vista/Win7 bootloader from the MBR again).
 
#6
Windows 7 is on my internal drive, and Ubuntu is on my External drive.
So you will need to do the following:


  1. Ensure that W7's HDD is first in the boot sequence of the BIOS.
  2. Ensure that both systems (i.e. W7 and Ubuntu) boot fine when you boot either one from the Windows boot menu,
  3. Try selecting "NeoGrub Bootloader" again from the Windows boot menu, then selecting the "Exit Grub" entry again, and press Enter.
  4. Post here what happens when you do this.
 
#7
I've now removed the entry that loads the windows bootloader again, and that stopped the windows 7 bootloader getting killed.

Unfortunately, for some reason that I haven't worked out, I could not get neogrub to boot ubuntu (It said the disk didn't exist, which is obviously not true).

I've now got both operating systems bootable again without easybcd. I ended up simply changing the boot order in the bios, then setting grub to use hd0,4 as root rather than hd1,4.

Now I just need to go into the bios and set which HDD I want to use to boot from to change between operating systems. Not ideal, but it works, whereas everything I tried using neogrub was simply failing.