BootMgr is missing - System Restore failed

#1
Hi everyone,

I've got a problem with my Vista installation and was hoping you guys could help me.

I have vista running for while now, and this morning when booting it showed Bootmgr is missing ctrl+alt+delete to restart

Now I've searched around for possible solutions and found the following which all didn't work:

  • Startup Repair (showed no problems)
  • Command prompt (same repair but first renaming the original bootbcd)
  • System restore (which showed 'system restore failed due to an unspecified error. Data error (cyclic redundancy check). (0x80070017).

I just hope my HD hasn't crashed, but I don't think so because otherwise the Vista boot wouldn't find any windows installations, would it?

Any help is appreciated.

Tobias
 
#3
Hadn't found that page yet.

I tried step 3 but failed at

x:\boot\bootsect.exe /nt60 all /force

it says that bootsect.exe is not recognized as an internal or external command, operable program or batch file.

When looking in the directory I can't find the bootsect.exe.
 

mqudsi

Mostly Harmless
Staff member
#4
bootsect isn't on X:\, it's on a random letter that is unique to your system. So you'll have to try a bunch of different letters until you find one that works for you.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
Hello,

Did you try other drives? It might not be n the C: Drive. Windows is not known for its ability to identify drives and partitions like other OS's. So what you may see as Drive C might truly be Drive D or E by other standards.

Cheers,
Mak
 
#7
No I'm certain it's c:, I only have one drive, one partition.

I've also tried, chkdsk (which fixed some clusters), fixboot, fixmbr, nothing seems to work.

However now I get the following screen when booting:

Windows failed to start. A recent hardware or software change might be the cause. (No new hardware has been installed.)To fix the problem:
Insert your windows installation disc and restart your computer
Choose your language settings, and then click 'next'
Click 'repair your computer'
(Which I did, it didn't help)
If you do not have this disc, contact your system administrator or computer manufacturer for assistance.

File : \Windows\system32\ntoskrnl.exe

Status : 0xc00000e9

Info : Windows failed to load becaus the kernel is missing, or corrupt.

I've also tried doing sfc /scannow which returned :" Windows Resource Protection could not start the repair service."

Any other ideas?