Bootsect problem

#1
Hi everybody,
my computer crashed a couple of days ago, due to power failure during a storm.
It doesn't boot but by downloading the recovery CD from here (thanks) I could boot and get to DOS.
Now the plot thickens. It's an HP desktop with a Recovery partition. When I tried the F11 thing it attempted to boot and the next time I got to the command prompt the drive letters were swapped. C: is now D: and viceversa...
Anyway, there is something wrong with the drive but I managed to connect a WD external USB drive and copy all my files, so my data is secured.

I can read the drive contents just fine with a DIR or COPY command. But when I tried the Bootsect command it worked perfectly on the Recovery partition but hangs on the main partition (the one containing Vista. Can anyone tell me if it's supposed to take long or there is something wrong here.

Thanks a lot
 
#3
Thanks for answering

I have tried everything I could find in this forum
chkdsk stops immediately and hungs there

Do you know of a good boot rescue cd that's free or not too expensive with a different disk checker?
The disk is a Seagate and I ran their disk check and it passed all the tests

Thanks for your help

Gonzalo
 
#4
Switched letters back

Update:
Managed to switch letters back, apparently the Recovery partition had become the Active partition. I made the partition where Vista is installed the Active one and it became C: again.
I don't know if this is a solution to the drive letter change in every case but it might help someone.

Still trying to find a disk utility other than chckdsk to scan the disk. I don't want to trash everything yet.

G
 

mqudsi

Mostly Harmless
Staff member
#5
Usually, if even chkdisk won't run, your drive is done for.
 

JustinW

Super Moderator
Staff member
#7
I've got an 8GB USB that appears to work fine but corrupts just about any files I put on there. So yep, even if you can view data now its a good sign its on its way out. And start copying now if you value any data on there.
 

mqudsi

Mostly Harmless
Staff member
#8
Check the S.M.A.R.T. status on the drive.
 
#10
While I am waiting for my HP disks to arrive I tried some more things

re formatted the HD , ran chkdsk, everything's fine
Restored the backup, chkdsk hangs

Ran sfc /scannow, no problems found in system files
Fsutil says the drive's dirty

G
 

mqudsi

Mostly Harmless
Staff member
#11
Hmm, only other solution that I can think of is to copy the contents of the partition over to another partition or a different disk; delete the old partition, create a new partition formatting it with NTFS (but *not* quick format!!!!), and copy the files back.

Give that a shot?
 
#12
I did it with a quick format, and chkdsk worked perfectly after that, then i copied the files back...same thing, chkdsk hangs...
I am receiving the HP original disks today, I'll try repair and recover from these and see If I get lucky...

Thanks

G
 

mqudsi

Mostly Harmless
Staff member
#13
See that's the point.

Quick format does not check for bad sectors. You need to mark the bad sectors before writing them.
 
#14
But I am sure the manufacturer's LONG test (seagate) does??!!
Anyway I will follow your advice and format the C: drive again ...
Should " Format c: /fs:NTFS" be enough or do I need to specify anything else...
Sorry, haven't done this in ages in DOS.

Thanks for you help

G
 

mqudsi

Mostly Harmless
Staff member
#15
Ah, I didn't know you used the long test. Yes, that should also do the trick..... Have you done it?
 
#16
Yes I did, twice, both the long and the short. No problems.
I will try with the original disks tonight.

If you have any other ideas let me know...I am kind of reticent to do a clean install when there doesn;t seem to be anything physically wrong with the drive.

Thanks for your continuing help

G
 

mqudsi

Mostly Harmless
Staff member
#17
Are you using /force with the bootsect command?
 

mqudsi

Mostly Harmless
Staff member
#19
You could try unmounting Vista partition with "mountvol c: /D" before running "Bootsect.exe all /mbr /force" and "Bootsect.exe all /force"
 
#20
bootsect /nt60 c: works fine after format but if I try to run it again (just to double check after copying the files back) it does not work.

Any idea of any file that might be causing this like hiberfil.sys or the pagefile if any of those were corrupted?

Thanks

G