Both XP/Win7 on 1 HDD and 1 SSD : Xp starts, win7 does'nt

#1
Thid is displayed by EZBCD under XP started from D:
---------------------------------------------------

There are a total of 2 entries listed in the bootloader.
Path: D:\Program Files\NeoSmart

Technologies\EasyBCD\profiles\NeoSmart.bcd

Default: Microsoft Windows 7 SSD
Timeout: None
EasyBCD Boot Device: D:\

Entry #1
Name: Microsoft Windows 7 SSD
BCD ID: {default}
Drive: F:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Microsoft Windows XP SSD
BCD ID: {f0b1eb82-ec13-11e4-a5bf-1c6f658f0cf0}
Drive: H:\
Bootloader Path: \NST\ntldr

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device boot
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {c2dee6fd-ec13-11e4-a5bf-1c6f658f0cf0}
resumeobject {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder {c2dee6fd-ec13-11e4-a5bf-1c6f658f0cf0}
{f0b1eb82-ec13-11e4-a5bf-1c6f658f0cf0}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 4294967295
displaybootmenu Yes

Windows Boot Loader
-------------------
identifier {c2dee6fd-ec13-11e4-a5bf-1c6f658f0cf0}
device partition=F:
path \Windows\system32\winload.exe
description Microsoft Windows 7 SSD
locale en-US
osdevice partition=F:
systemroot \Windows

Real-mode Boot Sector
---------------------
identifier {f0b1eb82-ec13-11e4-a5bf-1c6f658f0cf0}
device partition=H:
path \NST\ntldr
description Microsoft Windows XP SSD
locale fr-FR


The - non functional - situation is currently the following
=============================================================
One Disk : MBR
--------
- C: Windows 7 on partition 1 :
does'nt start (nor if in boot.ini nor if present)
State : System
- D: windows XP on partition 2 : starts and runs correctly
State : Start

boot.ini in C: (this disk) contains
-----------------------------------
[boot loader]
timeout=15
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP-Pro on

WD-320 C:" /fastdetect
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Windows XP-Pro on SSD

H:" /fastdetect


One SSD : MBR
-------
- F: Windows 7 on partition 1 same as above
State : ACtive
- H: windows XP on partition 2 same as above :
starts but runs witk many problems
State : None

At startup on this dosk, I get the messages
- starting windows from c:
- invalid boot.ini file and computer stops

This SSD was installed and initialized with a clon

>> It is impossible to start Windows.
>> I cannot use EZBcd to try fixing this
>> Wich of your Recovery disks should I use to repair : XP or W7?

By advance, many thnks.