bug in Edit Boot Menu

#1
in "Edit Boot Menu/Timeout Options the "Skip the boot menu" when checked the boot menu still shows the only way to disable the boot menu(not really it shows for a split second) is by setting "Boot default OS after" to 0 Seconds

this is not a major bug but one that should be fixable pretty easily
 

mqudsi

Mostly Harmless
Staff member
#3
It's probably an issue with your configuration. We've had reports of this before, and it's not an EasyBCD bug.

Try resetting the BCD from that option in EasyBCD. It should fix it.
 
#4
i have tried resetting all of the settings it still shows the boot menu

here is my Detailed view
Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  boot
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {8fa0e609-7d9c-11df-a290-0003253f9f63}
resumeobject            {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder            {8fa0e609-7d9c-11df-a290-0003253f9f63}
                        {8fa0e60a-7d9c-11df-a290-0003253f9f63}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 10
displaybootmenu         No

Windows Boot Loader
-------------------
identifier              {8fa0e609-7d9c-11df-a290-0003253f9f63}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
osdevice                partition=C:
systemroot              \Windows
resumeobject            {0b3ecaf4-7d9d-11df-a8cb-806e6f6e6963}

Real-mode Boot Sector
---------------------
identifier              {8fa0e60a-7d9c-11df-a290-0003253f9f63}
device                  boot
path                    \NTLDR
description             Windows XP
 
#5
Hi dlsmd,
I do not understand, why you have set the "displaybootmenu" to "No"?

What can you see in Win7 (Systemmanagement?-> Start and "Recovery?")?
I am a German with a German-Win7-OS and this is much different to US-OS in terminus for Shell and Folder and so on.
I mean the normal "Win7" Systemstart-Window, where you can see too the Startup delay time, the nominal starting OS and the possebility to set the delay time for Recovery options.

In this upper area you have to set "Viewing" the OS-Liste for "10" sec.
Without a marker in "Viewing", you have only set the 10 seconds, but you can not see the OS-Menu (boot menu) and the delay time is without function.
So it is on my system.

Greetings from Germany,
STRUPPI
 

mqudsi

Mostly Harmless
Staff member
#6
You can set the timeout to 0.
 

Terry60

Knows where his towel is.
Staff member
#7
Why do you want to suppress the menu when you have 2 OSs to choose between ?
If you don't want a dual-boot, delete the redundant entry from the BCD, (and the OS from your HDD(s))
 
#8
@STRUPPI
the reason why i want to disable the boot menu is i use iReboot to select which OS i want to use because i normally use windows 7 and rarely use windows XP (my computer cannot use XP mode in windows 7)

@Computer Guru
yes i can set it to 0 seconds (and the menu will virtually go away except for a blip when the menu shows for a fraction of a second ) i just thought that it was a bug that could confuse someone if they want to not show the boot menu using the same setup i do

@Terry60
the reason is iReboot handles it for me
 

mqudsi

Mostly Harmless
Staff member
#9
dlsmd: I love your reason for not using the boot menu!

I assume when you say you "reset all settings" you mean that you actually used EasyBCD's "Reset BCD" feature which reinstalls a BCD registry from scratch?

IF you are using iReboot in command-line mode, you can use this to solve your problem. Otherwise DON'T do it, or iReboot won't give you both options any more.

EasyBCD -> Useful Utilities -> Power Console
Type this in:

Code:
bcdedit.exe /displayorder {8fa0e60a-7d9c-11df-a290-0003253f9f63} /remove
 
#10
dlsmd: I love your reason for not using the boot menu!

I assume when you say you "reset all settings" you mean that you actually used EasyBCD's "Reset BCD" feature which reinstalls a BCD registry from scratch?
yup that is what i did

IF you are using iReboot in command-line mode, you can use this to solve your problem. Otherwise DON'T do it, or iReboot won't give you both options any more.

EasyBCD -> Useful Utilities -> Power Console
Type this in:

Code:
bcdedit.exe /displayorder {8fa0e60a-7d9c-11df-a290-0003253f9f63} /remove
i actually use it from start-up in my system bar(the gui version) so that wont help

this should be easily fixed by eather forcing timout to 0 or allow setting it to 0 after checking the box to not show boot menu
 

mqudsi

Mostly Harmless
Staff member
#11
It's not a bug with EasyBCD, it's a bug with Windows.
 

JustinW

Super Moderator
Staff member
#12
Unfortunately this setting doesn't work in all configurations. If resetting the BCD store doesn't do the trick you'll need to resort to timeout as suggested. Even when that option does work correctly it still may flash the boot manager briefly just like a timeout of 0 would, so no pros really.

I like how you want to avoid the boot menu. I should've done that on my laptop 2 years ago :smile:
 

mqudsi

Mostly Harmless
Staff member
#13
All hail iReboot! :smile:

I use iReboot but still keep the boot menu set to 3-5 second in case of unsafe shutdown.