Can Boot In IDE, Can't Boot In RAID 1

My computer has four drives in two RAID 1 arrays: two drives are for system files and the other two are dual partitioned system drives with Vista Ultimate 64 and XP Pro.

Several days ago one of the system drives failed. I replaced it and the RAID rebuilt without issue, but after all the start-up screens roll through, instead of getting the boot options screen, I get the \Boot\BCD error. If I reset the SATA options in the bios to IDE, I can boot into Vista without issue (though the XP partition doesn't show up in My Computer and all the HDs are listed separately, showing four drives total).

I've tried to repair the Start-Up in Vista (after booting in IDE mode) using Easy BCD version 2.0 but that doesn't fix the issue; when I switch back to RAID in the BIOS, I get the Boot error.

I've tried using the Repair Vista boot CD but it fails to see any OS and doesn't make any repairs. I haven't tried any of the other methods, because, well, I got a bit confused *embarrassed look* If I HAVE to wade in and try the DOS options, then so be it. But I'm hoping that since I CAN access Vista in IDE mode, there's a way to fix the boot issue and have it be recognized by the RAID controller.

One thing I was thinking of doing...I haven't replaced the OTHER original file drive, but I bought one so as to keep the pair of HDs as identical as possible. So what if I pull the original drive out, boot the remaining single drive into Vista in IDE mode, fix Easy BCD, then put in the new second drive, reset to RAID and when the RAID controller takes over, it should see the new drive and rebuild the array, hopefully with the boot options intact. Does this sound workable?

I'd like to recover the OS on the XP partition, but I'm not too concerned about not being able to boot in XP anymore. But I want to get access to the partition to recover other data stored there (though I did a back-up not too long ago so if I were to lose it--though the RAID controller says it's there and okay--it shouldn't be too catastrophic).

Thanks! :smile:
I had something possibly sort-of similar-ish once !!! I used parted magic on the UBCD CD to look at a pair of disks while they were all in IDE and the boot flag was set on one, but not the other after the RAID rebuild. I think I fixed it by swapping the SATA cables over - lol. It was very weird and suggested to me that the rebuild had not worked correctly although it said it had.

When you reset to IDE (ASUS mboard?) can you boot from the original disk, but not the copied disk?
Hi Twincam, thanks for jumping in. Yes, I'm running an ASUS mobo, P5B Deluxe.

I'm able to boot from the new disc, and I tried swapping the SATA cables like you suggested but I'm still not having any luck in RAID mode (I also tried the Vista Repair disk and Hiren's on the new drive--which during a previous mishap would let me boot either Vista or XP from its menu and from there--since I was in RAID mode--let me repair the EasyBCD parameters. No such luck now).

A new development I'm a bit leery of is how twice now when booting in IDE mode it's launched chkdsk, which I know can raise hell with RAID settings. After finally booting, Windows informed me that a folder was corrupt and couldn't be read, so I'm wondering just what the hell is going on (and hoping OTHER files aren't corrupt that I don't know about yet). I'm hoping the RAID controller isn't failing and writing corrupt data all over the place.

Since the mobo has both Intel and JMicron, I think I'm going to look into switching RAID controllers (I THINK I'm using the Intel controller. If so, the JMicro has more repair options than the Intel so I might be able to fix it that way). I'm not sure that's an option for me so I'll run a back-up of everything in IDE mode and then I should be okay to experiment.

I just wish some of the EasyBCD folks would jump in with some ideas, tho'... :frowning:
it's always a bit iffy, jumping in and out of raid mode for obvious reasons, but I can't see why IDE mode would give you issues on its own.

It sounds more like a raid controller issue than a boot issue to me. What I mean is that what you see as a won't boot, could be a fundamental issue with the raid controller. The first time you try to use it will be during the boot, so if it just isn't going to work, it'll fail then.

What differences are there between the two disks?

I'm not clear exactly what is on this pair of disks, is it an OS? I'd take a backup of your surviving drive, get your two new disks running together in raid, then recover your data to the raid pair.



and when i say issue with the raid controller, i mean its ability to cope with two different disks. trying the other raid controller might work, it might be better at managing two different disks. many manufactur3rs say that you can raid across two different disk types, but they all recommend using two the same, and they can't test all combinations.
Last edited:
The two disks are System disks, split into two partitions, one for XP Pro and the other for Vista Ultimate.

So I had a moment of joy followed by sorrow last night. The two original drives were Seagates and the two new ones are Western Digitals. While having all these problems, I've been running a mix of the surviving Seagate and one of the new WDs. So I replaced the original Seagate with the second (new) WD and the RAID controller changed status to REBUILD and joy of joys, went right into the EasyBCD boot menu and let me boot into Vista (I still haven't been able to reset EasyBCD to give me the XP option).

So I looked away for a moment and in that time Windows changed some configuration settings (it didn't tell me what) and when I glanced back I was greeted with the "Your computer must restart to implement these changes. Restart now or restart later". Thinking this had something to do with the RAID rebuilding, I clicked Restart Now and the computer restarted...and has been unable to boot since. I get greeted with the "No OS detected, Insert boot media.." thing.

By booting from the self-contained Mini XP on Hiren's, it's clear that the RAID is handling the separate discs properly: I can see the XP and the Vista partitions as separate discs and all the data SEEMS to be there, so I'm guessing that the EasyBCD folder is where the borking occurred which is why the RAID can't get the system to boot.

So my next course of action will be to try and install EasyBCD from a thumbdrive in the RAM folder while the Mini XP is mounted and see if I can't fix the boot issue that way. If THAT doesn't work then I'm just going to toss two NEW drives in there and start from scratch. Spending a couple'a days re-installing all my software and migrating the data from the old drives to new drives with a fresh install of Windows seems like a quicker and better fix than spending a week or so trying to troubleshoot and stabilize an unknown and unpredictable system. I'll post an update when I resolve things one way or the other.

And I just want to thank you again for jumping in to help. There's nothing more frustrating then having an issue and asking for ANYONE to step in and no one does. Your taking the time to help me resolve this has helped me learn more about my RAID and restored some faith in my fellow humans...:smile:


Knows where his towel is.
Staff member
EasyBCD doesn't take any active part in booting your system, or do anything else on a running system, unless you run it and ask it to do something.
There is no "EasyBCD boot menu". That's Microsoft, all the way down.
EasyBCD is, in essence, an app for managing the contents of the BCD, though it has developed many bells and whistles over the years that allow you to chain from the MS boot manager to multiple environments that MS never contemplated.

Sorry not to have been of any help to you, but your problems all seem to be RAID-related, and as a permanent non-user, my policy of not offering advice on subjects about which I know nothing takes effect.

When you've completed your "square-one" policy, I'm sure you'll find that EasyBCD will set up your boot with no problems, but should you experience any difficulty, post back and you'll find plenty of prompt help.

Again, sorry not to have been any help on this occasion, but at least the forum allowed some p2p support.
It's all become too complicated! There are too many possibilities and probably multiple small problems overlaying themselves. It does look like it's all basically working and a back-to-scratch rebuild sounds like the best way to go.

I recently ran a quick test on an HDD that failed in Raid-1 about a year ago (never bothered to take it out of the PC) , and it was fine. It's now back in a PC and running perfectly.

I'm now considering buying drives in threes, a raid pair and a third one for d2d backup. Then if one of the raid pair fails, I have an identical disk ready to take over and I can buy any old disk to replace the backup disk.

I think the important thing is to get the raid pair rebuilt as soon as possible, ideally on the next reboot!

Good luck and thanks for the kind words. :smile:
Thanks again, everyone.

Terry, my apologies if I came off sounding snarky towards EasyBCD. I recognize that this is a donation-supported application and I respect that there's a limit to what can reasonably be done to help folks like myself whose problems drift into areas that--upon examination--probably aren't related to EasyBCD after all.

And Twincam, yeah, I agree that's getting absurdly complicated so I think it's time to do some spring cleaning with things. Thanks again!


Knows where his towel is.
Staff member
No problem Des.
You'll get plenty of support for all sorts of non-EasyBCD problems too (as a quick skim through the Windows, General and Hardware forums wil illustrate), provided of course that one of the regulars actually has any expertise in the problem area.
RAID experts just happen to be a bit thin on the ground.
Hopefully Alan will stick around, and maybe your own research will lead to a level of expertise that results in you being the RAID go-to guy.
We're all (the mods), just users who came for Easy, asked a few questions, answered a few more, passed on what we'd learned, and never got round to leaving.