Can not dualboot Windows 7x64 & Ubuntu 10.04 using Easy BCD

#1
I have windows 7 x64 installed on my C partition and I have a separate partition that was unformatted. I installed Ubuntu 10.04 on this partition and put no bootloader on advanced options during installation. This is the third time I am installing Ubuntu. I keep having trouble with Grub it will work sometimes and then once in a while after my bios screen my computer will be stuck in an infinite loop it wont load into grub for me to choose my OS and I have to reinstall everything. Really gets annoying. So this time I just installed W7 x64 on my C drive and left my other partition unnamed without a drive letter. I installed Ubuntu 10.04 on the largest free space available without bootloader. I figured when I loaded into windows I could use Easy BCD to install a linux boot option into the Easy BCD menu. I did this and nothing works. I even tried this method from LIMNEOS:

Windows 7 after a clean install, it creates a small 200MB hidden partition to store the BCD store database. (similar files to boot.ini). This is where the bootloader is stored.
This partition is currently invisible to you, so even if you added a linux boot entry in EasyBCD, easybcd thinks that it has written the files to the partition where the bootloader is, but it actually can't write there cause it's hidden (no drive letter given). To fix that, open Disk Management, assign a drive letter to your hidden small partition (200MB of size must be), and then add a linux boot entry from EASYBCD again. This time it should work and you should be able to dual boot.

Still does not work. I can load into windows from the EASY BCD boot menu but I cant load into Ubuntu. It is installed but I can’t access it. Any tips?

 
Last edited:

JustinW

Super Moderator
Staff member
#2
See if \NST\NeoGrub.mbr exists. If it doesnt but you see something like AutoNeoGrub.mbr make a copy and rename to NeoGrub.mbr.
 

mqudsi

Mostly Harmless
Staff member
#5
Congratulations. :smile:

You can renamed the "Recovered" entry to get rid of that text.
 
#6
PLEASE POST SOMETHING ABOUT the 2.0 VERSION on the main site!!! I just spent like 4 hours trying to figure this out only to find it now after registering and looking here!
 

mqudsi

Mostly Harmless
Staff member
#7
Hi duprade,

Welcome to NST. I think I'll do that, thanks for the suggestion :smile:
 
#8
Hi, i have the same problem with no booting Ubuntu. I mean, i have the answer of the problem.

It is important, that the Partition where Unbuntu should be installed is formatet in ext3 Filesystem. Multiboot won`t work with ext4-Filesystem.

In Easy BCD 2.0.0.94 press the "Bootloader Setup" Button and the "Install BCD" Button. Please be sure, that you install BCD in the "hidden" Partition with ca. 200MB.
You see, that the "Edit Bootmenu" is empty, so that you have to add new entrys.
To add Win7 you can use the default settings.

To add Linux (Ubuntu) be sure that you select Grub2.

At start of the PC the WinBootmanger starts and you can select the OS you want.
When you select Linux then is Grub2 loading and you can select again one of the installed OS.


Please excuse my bad english, because I`m an old german man. I hope, you can understand my little "Walkthru". - On my PC it`s works fine :smile:.

Thank`s for this Great Tool. But, is it possible, to add the ext4-Filesystem?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#10
Ashoka, EasyBCD should work fine with ext4.
 
#11
Hello,

I don't know if this will be helpful or not at this stage in the game, but here is a simple guide on steps I used with EasyBCD 2 beta to reinstate the Windows 7 bootloader and have an option on it to point to Ubuntu 10.04's. For particulars, I had installed 7 first, then added Ubuntu 10.04 later; though Grub provides a boot menu, I just felt more like using Microsoft's bootloader instead. I hope this helps some people out:



1. On the View Settings page, we see the current Windows bootloader info (no changes yet). Only 7's information is listed




2. Click the Add New Entry button and:
----- click the Linux/BSD tab
----- in the drop-down menu, click Grub 2
----- in the Name box, type what you want to appear in the boot menu for Ubuntu. Here, I used "Ubuntu 10.04" for example
----- click the Add Entry button




3. If you want to change anything like the amount of time the bootloader waits for you to do anything at the boot menu before loading the default OS in the list, click the Edit Boot Menu button and change it here. You should see the new entry for Ubuntu, too, after the previous step. I changed the time out to 7 seconds instead of the default 30 seconds in this example. If you make any changes, hit Save Settings




4. Click the Bootloader Setup button, then on the right make sure the radio button "Install the Windows Vista/7 Bootloader" is dotted, then click the Write MBR button. It should write the changes, then you can close the program and restart the computer to see your new Windows bootloader menu!

Thanks to Neosmart for this great little program over the years. Help them out and donate! :smile:
 

mqudsi

Mostly Harmless
Staff member
#12
Hi Shomizu9, welcome to the forums!

Thanks for your illustrated guide, I'm sure it'll come in handy. As they say, a picture is worth a thousand words and I haven't had a chance to update our own illustrated tutorials in the wiki for EasyBCD 2.0 as of yet :smile:
 
#13
Hello Shomizu9,

Thanks for your tutorial, it helps me solving my problem, now i can use Microsoft's bootloader to choose between Seven and Ubuntu, however i still have a problem, if i choose the ubuntu, then the grub appears, can you tell me how i can fix this? I want to choose the ubuntu in Microsoft's bootloader and he goes runs directly instead of goes to grub.

Sorry for my english, thanks again for your tutorial.

Regards
 

Terry60

Knows where his towel is.
Staff member
#14
#16
What to do with command prompt \Grub?

See if \NST\NeoGrub.mbr exists. If it doesnt but you see something like AutoNeoGrub.mbr make a copy and rename to NeoGrub.mbr.
Hi kairozamorro, after doing what you suggested and restarted, I still get the command prompt: /Grub.

I am new to linux and just haven't got around with what to do from there.

Can you help further?

System OS:
Windows7 Ultimate
Ubuntu 10.4

Thanks:smile::shame:
 
#18
Hi, I have vista, ubuntu and xubuntu (both 10.4) installed. I can setup dual boot ubuntu and vista without any problem. But when I add xubuntu, I have a problem. I added xubuntu by the same way with ubuntu. But they are installed on different partitions which could not be choosen for grub2.

When I select ubuntu and xubuntu from the boot menu, ubuntu start.
Is there any suggestion? How can I add two different grup2 menu item? Did I do something wrong?
 
#19
When I select ubuntu and xubuntu from the boot menu, ubuntu start.
Is there any suggestion? How can I add two different grup2 menu item? Did I do something wrong?
You need to add an entry for xubuntu to the /boot/grub/boot.cfg on your Ubuntu partition.
 
#20
I found another solution:
From easybcd I added NeoSmart NeoGrub Bootloader. And I added below lines to c:\NST\menu.lst

Code:
default 0
timeout 1

title       Xubuntu 10.4
root        (hd0,7)
kernel      /boot/grub/core.img
in linux hda8 becomes hd0,7 here.