Can only boot in to Vista with install disk in cd-rom

#1
For some reason my install got messed up and I get the old "no Os present strike any key when ready..." if the Vista CD is not in the CD rom...

... if it is it goes through the "strike any key to boot in to installer.. yada yada yada and then gives me 2 boot loaders to choose from (this is a single OS configuration though - something ogt messed up and I had to reinstall - but no dual boot)

I tried using EasBCD to fix it but I really do not know what i am doing.

The C drive is a hardware raid 0 array I have not had issues with in the past and there is one more D drive on the system - ededit.exe shows this output:

Code:
Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>bcdedit.exe

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 5
resume                  No

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows Vista
locale                  en-US
inherit                 {bootloadersettings}
osdevice                partition=C:
systemroot              \Windows
resumeobject            {e8709fb7-fa5f-11db-be4d-e219ece5282e}
nx                      OptOut

C:\Windows\system32>
Any ideas?
 

JustinW

Super Moderator
Staff member
#2
Hello Thaidog, welcome to NST,

Thats normal. The first entry is nothing more than telling bcd where it can find itself. It shouldn't be appearing at boot up.
 
#3
Hello Thaidog, welcome to NST,

Thats normal. The first entry is nothing more than telling bcd where it can find itself. It shouldn't be appearing at boot up.

Ok so how do i get rid of the neeed to put in my install disk just so I can boot in to my OS and not get "no os found..." error?