Cannot dual boot windows 7 and ubuntu

#1
I have dual booted windows 7 and ubuntu. I installed ubuntu last but I wanted to use the windows boot loader so used easyBCD to rewrite the MBR and added grub2 to the mbr record. ubuntu is located on a separate drive drive and partition. As recommended here Multibooters, Vista Dual and Multibooting - A Guide to the Multiboot Process I have placed grub entirely on the linux partition however its is still not working.

I now get the two boot options, windows boots correctly but I get four or five 'try (hd0 0) non-ms skip' lines when I select ubuntu
 

Terry60

Knows where his towel is.
Staff member
#2
Are you using the very latest version of EasyBCD ?
Software Library - NeoSmart Technologies
Latest Ubuntu architecture changes were not catered for in 2.3 which pre-dated them
2.4 included fixes for that problem.
 
#3
Hi Terry,

I am using EasyBCD 2.4

The bootloader settings are:-

Default: Windows 7
Timeout: 30 seconds
Boot Drive: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: NeoSmart Linux
BCD ID: {8ff7cc47-6892-11e9-858d-f3055ff50c0c}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

I'm not sure what the bootloader path on the second entry is doing. When I created that entry I selected the ubuntu partition which is on a different drive.
 

Terry60

Knows where his towel is.
Staff member
#4
It's chaining via the Neosmart (NST) folder.
Sadly that's where my Linux expertise ends.
I haven't used it for many many years (there was no grub2 on my last Ubuntu, that's how long ago it was)
I'm afraid you'll need someone with current Ubuntu knowledge to help out.
You might get a faster response in an Ubuntu forum than here.
 
#5
It doesn't look like it is getting as far as the linux installation as it is looking on the wrong drive. Would it be possible for someone to look at the
AutoNeoGrub0.mbr to make sure it is correct?
 

Terry60

Knows where his towel is.
Staff member
#6
It's not looking on the wrong drive, but the AutoNeoGrub file is obviously incorrect.
Did you let EasyBCD find Linux and configure the boot chain automatically ?
That's why I mentioned 2.4
The auto-configuration failed in 2.3 when Ubuntu changed the boot architecture in some way which affected that chain.
A fix to accomodate the Linux redesign was incorporated into 2.4
 
#7
I tried letting EasyBCD automatically find linux but getting the same result. I'm assuming ubuntu 16.04 uses grub2.
I generally select write MBR after any changes. What does the Install BCD button do?
 

Terry60

Knows where his towel is.
Staff member
#8
No wonder nothing works.
DONT "WRITE MBR"
That's for restoring an overwritten Windows boot (by XP or Linux or some accident) and will remove anything you thought you'd just changed.
Just add an entry.
That's it.
 
#9
Ok. Someone on a forum recommended always doing it after any changes so I guess I'm not the only one. I interpreted 'install the vista + BCD/bootmgr bootloader' as meaning write the new BCD boot menu to the disk. Anyway, not doing it doesn't make any difference. I'm still getting the same error.
 

Terry60

Knows where his towel is.
Staff member
#11
Sorry, my use of Linux qualifies as ancient history, so I can't help with contemporary problems.
 

Terry60

Knows where his towel is.
Staff member
#13
This is a user to user forum so you just have to hope that someone else has experienced (and solved) your problem and is around to see your post.
 
#14
Well its been nearly a month so that seems unlikely. Maybe I'll just post it again. I'm not trying to do something complicated, just dual boot a machine.
 
#15
I'm having the EXACT same failure trying to dual boot Win7 and Mint 19 (ubuntu 18.04). Both drives are showing as MBR. I can boot into either OS by selecting the appropriate drive from BIOS. EasyBCD won't find the Grub2 on the Linux SSD so it isn't working for dual boot.

To quote rjjaconbs; "I now get the two boot options, windows boots correctly but I get four or five 'try (hd0 0) non-ms skip' lines when I select ubuntu"
 
#17
I have the same problem on Win7, trying to boot the iso of Acronis Trueimage.
I'm using EasyBCD community version 2.4.0.237

The full error i see when i select the second boot entry is:
Try (hd0): non-MS: skip
Try (hd0): non-MS: skip
Try (hd0): non-MS: skip
Try (hd0): non-MS: skip
No floppy
Cannot find ANG0 in all drives. Press Ctrl+Alt+Del to restart.


Any ideas?
Thank you