Cannot get a bootable USB drive to work in aid of repairing Vista's boot files.

#1
Hey there fellas,

After being up for 6 hours straight trying to solve this, I have reached the conclusion that something is going very wrong somewhere.

So earlier I was playing BF3, (which took me all day to get working due to its own problems), and then ten minutes into a game, the computer crashes in a fashion not uncommon to BF3 - screen tearing, immediate reboot kinda thing.

But when I expected it to just boot in normally, it gave me some error about the Boot.ini. An error I've had a few times in the past as a result of spontaneous restarts.

So I searched and searched, got EasyBCD, and went to make a bootable flash drive, as both my CD/DVD readers are dead, and no amount of taking them apart was able to fix them, meaning I couldn't use my repair disk, which has saved me in the past. So, I've tried numerous different things, checked out these two threads:

Unable to load Windows after using EasyBCD to write MBR (the OP here seemed to have a similar problem to me at the start which somehow went away and led to different problems for the guy)

How to make a windows 7 or Windows Vista USB Recovery Stick (thumb drive) (Post #7 here had some nice clear instructions by the guy who apparently wrote the thing, so I used them as my main guide, even though they are worded for an outdated version, I think I followed them precisely)

I paid close attention to various instructions. Now I have a flash drive formatted to NTFS (which was the only format that'd actually register in the boot order/BIOS). It has Windows Vista x64 Recovery Disc on it, I went to Add New Entry and set up the Iso as mentioned in several places, including one of those links, but no matter what I do, it will just not work. I boot from the USb drive and receive the error "The windows boot configuration data file does not contain a valid os entry", I'm assuming it's referring to the USB drive, as it never gets further than the boot.ini error when I don't try to boot from it.

I tried putting the bare files from the DVD itself onto the flash drive via my laptop, but that didnt seem to change anything.

Would anyone be so kind as to give me a little help please? I'm at the end of my tether.

I hope I've not missed any info out, I'm extremely tired. Also a reformat is completely out of the question, I have to recover this somehow, I'm sure it's something I've missed.

Oh and as I've seen it mentioned in other threads, I don't have the option for the F8 Advanced menu thingy. My Mobo is a Gigabyte Ga-P35-DS3L, I'm pretty sure.

Cheers!

EDIT--------------

Ok, so after much experimenting it appears it wasnt booting from the flash drive previously due to the NTFS file system being created using the express option. It boots into the repair environment fine if I go the long route, however after repairing, it seems I can only boot into windows using the flash drive, If I remove it and try to reconfigure for how it was originally, I receive the same Invalid Boot.ini error message.
 
Last edited: