Cannot Install PCLinuxOS - Hard Drive Full Error

5x5

New Member
#1
Hello all.
I have a problem that I don't see referenced anywhere in the forum that I could find and I am praying that someone can help me.
I just got a new box with Vista Premium already installed on a single 320g SATA drive. I figured out that I needed to shrink that drive and create a partition to install PCLinuxOS (my OS of choice) so that's what I did from the Disk Management console in Vista. I left it as a Simple Partition and did not format it at all and chose not to assign a drive letter or path to it from within Vista.
Now, when I boot to my PCLOS Live CD and start the install, I get an error telling me that there is no space to install.
Do I need to go ahead and format that new partition as NTFS and assign a drive letter for PCLOS to 'see' it? Also, are there any other pitfalls ahead that I need to be aware of? I've never used Vista before now and I've never had a SATA drive sooooo.......I'm a little nervous here.\
I have EasyBCD already installed and ready to go as soon as I can get this snag worked out.

Many thanks in advance if anyone can help me!
5x5
 

mqudsi

Mostly Harmless
Staff member
#2
Hi 5x5, welcome to NeoSmart Technologies.

It's either a SATA issue or a partitioning issue - it depends on where exactly PCLinuxOS fails.

Does PCLinuxOS see the partition that you created and just can't write to it because the partition is full? Or does it not see the drive in the first place?

If you're using automatic mode, you might want to choose manual so as to select the partition yourself.

(BTW, this isn't (yet) an EasyBCD issue, so moved to the General Support section :smile:)
 

5x5

New Member
#3
RE: Vista + PCLinuxOS.....oh my.

Hi Guru.
PCLOS does not see the SATA drive AT ALL. I decided to go ahead and format that partition in Vista to see if that was the problem and on retrying the PCLOS install, I got far enough to see that the SATA drive is simply invisible to the install. On prior installs of PCLOS, one of the first steps is to select a network driver for use with ndiswrapper and I was able to browse through my windows files at that point. With this SATA drive and Vista....I click on win_c and it's just empty. The partitioning utility in PCLOS shows a Windows partition (which is where I expected Vista to be) but it was just a miniSD drive mounted.
Do you know of anything I can do? I'm stumped (which isn't really saying much).

Btw, sorry about posting in the wrong location. Thx for putting me where I belong.
:smile:

Addendum:

Hi 5x5, welcome to NeoSmart Technologies.

If you're using automatic mode, you might want to choose manual so as to select the partition yourself.

Almost forgot this part......what do you mean by 'automatic mode'?

Also, just an FYI....it is taking an average of ten minutes to load this single webpage. Are there server problems?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
10 minutes or 10 seconds? Here it's taking 20 seconds to load :x

Yes, there are problems. If you promise to keep it quite I'll let you in on a little secret: we have a new server (Dual-Core Conroe) and will be moving in the next couple of days! :grinning:

I actually forgot to move your post, I did so now - don't worry about it, happens all the time :smile:

I've never actually installed that particular Linux distro myself, so I wasn't sure if it had automatic vs manual mode partitioning like Ubuntu and Fedora have - no problem though.

OK, anyway, it sounds like PCLinuxOS doesn't support your SATA controller out-of-the-box, check if your motherboard is listed here in their hardware compatibility database: The PCLinuxOS Hardware Database - Hardware - Motherboards
 

5x5

New Member
#5
PCLOS does have something like 'automatic' partitioning, yes....I just always go for the custom so I know what's going to happen. I'm checking out the motherboard issue right now. If it's not supported, I think I'm going to have a breakdown. :frowning:

And about the site load time.....no kidding....more than ten minutes! Ha. Congrats on the new server, tho. :wink:

Addendum:

Well, I've had an eventful day. I found all kinds of references to other people getting some form of linux up and running with my motherboard so I don't *think* that's the problem. However, after spending a day digging through forums I think it may have something to do with RAID. My motherboard has nvidia RAID support (which was enabled for some weird reason even though I only have a single hd) and when I disabled that in the BIOS, PCLOS did, at least, see the drive. THe only bad thing is that it still sees it as an array. I'm assuming that's what it sees since it's calling the devices 'mappers'. When I go ahead and try to resize the Windows partition on sda, it says it can't be done. The device is 'busy'. It tells me that some other software is using the disk and partitioning can't continue. ??? What other software would be using the disk since I booted to a live cd?
Anyway, I know this is not the place for this post so I am off to the pclos forums. Thx for your help so far!
 
Last edited:

5x5

New Member
#6
Can't boot into Vista OR Linux....

After continuing to try all sorts of configurations yesterday, I finally tried to install openSuse 10.3 on a second partition that I created from within Vista. Strangely enough, openSuse saw the second partition and its correct size but still saw it as a RAID array. I decided 'what the heck'. I'll try it anyway. I used custom partitioning on the first installation attempt since I'm not familiar with this distro and what it does during the partitioning phase (very weird, btw) and ended up with like 8 different paritions. ?? So, I tried it again and let the distro decide how to arrange that second extended partition and it seemed to go fine right up until the installation was almost complete, all the packages had been copied to the disk, etc....and it hung up on installing the bootloader. I tried Grub the first time and I don't think it ever installed at all b/c I booted back into VIsta, opened EasyBCD, made the correct entries according to the documentation......opensuse wouldn't boot. I tried pointing EasyBCD at every partition....nothing. On the second install attempt when I used Lilo, I got one error that said the boot sector wasn't 'active' so I went back, found an option to activate it and the install finished up and rebooted into Vista. Did the EasyBCD thing again....nothing. No openSuse. No Vista. I have a nice, white, blinking cursor at the top left corner of a black screen. :smile:

Does anyone know how to get one of these os's to boot up? I am not, by any means, a linux wiz. I tried booting to the openSuse install cd and doing both 'rescue' and 'repair' and it dropped me at a cursor and I had no idea what commands to use or what to do.

Here's a strange little follow up to PCLOS. After the first install of openSuse where Vista was still accessible, I booted to the pclos live cd and it still thinks there is no hard drive even though it's there, formatted ext3 and has a unix os installed. ??


Many thx!
5x5

Addendum:

Well, I wish I could say the problems dual-booting Vista and PCLinuxOS on this new machine of mine were solved but I think they've been nailed down anyway.
The current PCLinuxOS kernel does not support the type of SATA drive I have and possibly does not support the nvidia RAID as well. However.....there will be a new PCLOS release coming soon (hopefully within the next few weeks) based on the newest kernel and it will include that support.
This was the reason that openSUSE could see and install to the drives and not PCLOS. 10.3 is based on the latest kernel.

Long story slightly less long.....I just have to do without my beloved PCLOS for a little while. But you know what they say......absence makes the heart grow fonder.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
:lol:

Well, I'm glad you pinned it down - hopefully it'll be working in their next release?
 

5x5

New Member
#8
Yep, the newest kernel supports those SATA drives. The way I understand it, the problem is referred to as a SATA-IDE loopback error. lol. Whatever that means.
 

mqudsi

Mostly Harmless
Staff member
#9
Well, the literal translation is that data is coming from the SATA controller and going into the IDE controller, causing data corruption.. :tongueout:

Doesn't really matter though, what's important is that it works in the next release!! (any idea when that is?)
 

5x5

New Member
#10
The 'powers that be' at the pclos forums tell me that it will be very shortly....from a week or so at the earliest to 2 or 3 weeks. Can't wait.
:joy: