"Cannot load from harddisk" Error

#1
I've noticed some pretty helpful readers posting answers here, and after a lot of searching I've been unable to find a similar situation; so I've come in hopes of finding resolution.

I'm trying to run a Tri-Boot system (Vista - XP - Ubuntu 7.04) and use EasyBCD 1.61.0.21729 to configure my boot. I prefer to use Vista's boot manager to boot into Vista and XP and to chain-load into the GRUB menu. When I try to boot into Linux, I receive the error:
BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant http://www.winimage.com/bootpart.htm
Loading new partition
Bootsector from C.H. Hochst„tter
Cannot load from harddisk.
Insert Systemdisk and press any key.
Now, If I press any key... GRUB will BOOT! Ultimately, I would like to either replace/edit nst_grub.mbr to not require to 'press any key' or to configure EasyBCD to allow it to work properly.

Hard Drive Configuration:
Physical number of disk 0 : 20fb6
0 : C:* type=b (Win95 Fat32), size= 244196001 KB, Lba Pos=63
[STORAGE]
Physical number of disk 1 : 54be3587
1 : D:* type=7 (HPFS/NTFS), size= 102398278 KB, Lba Pos=63
[WinXP]
2 : D: type=83 (Linux native), size= 200812 KB, Lba Pos=204796620 [/boot]
3 : D: type=7 (HPFS/NTFS), size= 102406342 KB, Lba Pos=205198245 [WinVista]
4 : D: type=5 (Extended), size= 107563207 KB, Lba Pos=410010930
5 : D: type=b (Win95 Fat32), size= 72702126 KB, Lba Pos=410010993
[STORAGE]
6 : D: type=5 (Extended), size= 4192965 KB, Lba Pos=555415245
7 : D: type=82 (Linux swap), size= 4192933 KB, Lba Pos=555415308
[SWAP]
8 : D: type=5 (Extended), size= 30668085 KB, Lba Pos=563801175
9 : D: type=83 (Linux native), size= 30668053 KB, Lba Pos=563801238
[/]
Physical number of disk 2 : 628688ee
10 : E:* type=7 (HPFS/NTFS), size= 488384001 KB, Lba Pos=63
[STORAGE]
My BIOS reads:
IDE Primary: 250GB HD
IDE Secondary: CD-RW/DVD-RW Drive
SATA 1: 320GB HD
SATA 2: 500GB HD

*** System BIOS is set to boot from SATA 1: 320GB HD ***

I believe my device.map in Ubuntu grub looks like (this is from memory, but I'm sure of the assignments):
Code:
[FONT=Courier New](fd0) /dev/fd0
(hd0) /dev/hda
(hd1) /dev/sda
(hd2) /dev/sdb[/FONT]
What's been done and Settings:
Installed Ubuntu: sda7 is the / partition, sda2 is the /boot partition, and sda6 is the swap. GRUB was initially installed on (hd1)
Installed XP. Grub was overwritten at this point.
Installed Vista. Installed EasyBCD 1.61 :grinning:
Booted into Ubuntu liveCD, did:
Code:
$> [FONT=Courier New]sudo grub
> root (hd1,1)
> setup (hd1,1)
[FONT=Arial]<Message stating success>[/FONT]
> quit[/FONT]
Back in Vista, Setup a profile for Ubuntu under Disk 1, Partition 1 (Linux Native 0GB) - which seems to link up to Physical Disk 1 #2 from my bootpart.exe above.

So now I get that error, but if I press any key... it boots!... I have a feeling this error is from my motherboard assigning my IDE HDD as the first disk in the list, but booting from the SATA1 HDD instead (bios DOES have this as the boot HDD).

Some more information:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=D:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {85fb244a-4ef1-11dc-bc4f-d71ecc496d5e}
displayorder {466f5a88-0af2-4f76-9038-095b170dc21c}
{85fb244a-4ef1-11dc-bc4f-d71ecc496d5e}
{6fdeb662-4f6f-11dc-a511-0019db5f739b}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 15

Windows Legacy OS Loader
------------------------
identifier {466f5a88-0af2-4f76-9038-095b170dc21c}
device partition=C:
path \ntldr
description Earlier Version of Windows

Windows Boot Loader
-------------------
identifier {85fb244a-4ef1-11dc-bc4f-d71ecc496d5e}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice partition=C:
systemroot \Windows
resumeobject {85fb244b-4ef1-11dc-bc4f-d71ecc496d5e}
nx OptIn

Real-mode Boot Sector
---------------------
identifier {6fdeb662-4f6f-11dc-a511-0019db5f739b}
device boot
path \NST\nst_grub.mbr
description Ubuntu Feisty Fawn
Some random info if proves useful:
MB: MSI K9N Platinum (forget the bios v... I think 1.8)
CPU: AMD 64 5600+ (2.8GHz dual core)
OSZ Platinum something
nVidia 7600GT KO
Some TV Tuner
CD-RW/DVD-RW

I have the capibles of reading the nst_grub.mbr in HEX form, and can post it if maybe useful.


So is there a fix to this problem? I know it sounds silly to go through so much to not have to enter another key at startup... Well, I guess it is - but I'd still like some resolution.:tongueout: And I also post since this could uncover a bug, or correct human error that other souls are dealing with. (IDE And SATA - booting on SATA)

Thanks!
Marc
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Marc, welcome to NST.

Actually, off the top of my head, we had one other member with the same exact issue, drove us nuts getting it pinned down.

I guess the integrity checks are failing at some point, though it ends up working anyway.

Solution:
Grab EasyBCD 1.61 beta, and use the new grubless-Linux option (Add/Remove Entries | Linux | "GRUB isn't installed")

That should bypass that screen :smile:
 
#3
An update, more info

Thank you for the reply, and I'll give the grubless linux boot a try. I think I tried that before, but didn't invest any time into it, and don't remember it working right away. I'll take a look at the configuration another step before I comment on that any more.

Some information that I've pieced together since, you'll notice that the easyBCD printout has it booting from the C:\ Drive for both Vista and XP. This is how easyBCD (or Vista Install) setup things up.... Now the Drive assignment is wrong. In Vista, the Vista partition is the C:\ Drive and XP is the D:\. In XP, The XP drive is C:\ and Vista is on D:\. This is something Window's did, but I favor since a few programs I use work better with C:\ as an absolute path.

But XP did not boot when it points to the C:\ Drive. I needed to modify the drive to boot from to boot from D:\ntldr

Another oddball. When installing Ubuntu, Ubuntu made the menu.lst "root (hd1,1)", but this would fail to boot. I had to edit menu.lst to have (hd0,1) instead.

Then after installing windows and easyBCD, I would get that error message, press any key to continue to the GRUB screen, and error. I went back into menu.lst and changed it back to (hd1,1) and things worked.

In my humble opinion, somewhere along the line there's an inconsistency of what order the hardware is seeing the drives under. It seems to be rooted from having an IDE hard drive but using an SATA as a boot. It looks to me as if hardware says the drive mapping is one thing, and once software comes, it switches things around, messing up any low-level booting operations.

Thanks again!
 
#5
Hi Marc, welcome to NST.

Actually, off the top of my head, we had one other member with the same exact issue, drove us nuts getting it pinned down.

I guess the integrity checks are failing at some point, though it ends up working anyway.

Solution:
Grab EasyBCD 1.61 beta, and use the new grubless-Linux option (Add/Remove Entries | Linux | "GRUB isn't installed")

That should bypass that screen :smile:
Just wanted to say that this worked perfect for my triple boot (XP/Vista/Ubuntu) which I have on 2 drivers (XP/Vista on one, Ubuntu on the other). Thanks for the great work!
 

mqudsi

Mostly Harmless
Staff member
#6
You're welcome! That's always good to hear :smile: