Cannot load from harddisk

#1
But I don't know why not, even after reading and trying for hours.

I have an HP dv9000z with two internal drives. The first one is all Vista Home Premium, the second is 35 gig of Windows partition, 70 gig of Ubuntu 7.04 64-bit.
I prefer Ubuntu, but have to use windows 32-bit for the iPhone (another complaint against Apple's iPhone attitude). O.k., Wednesday morning my wireless card refused to work for the first time in a year. I booted Ubuntu, and still no wireless, so I cabled to the router and Ubuntu was happy. Thursday, I called HP, and the (Windows-ony) tech had me load a new wireless driver, and a new BIOS. Still no wireless card, so I'm supposed to send in the machine for repair. So, I plugged in a Maxtor 320 gig USB drive, backed up Windows. But drat! now I can't boot Ubuntu. Been stuck there since Thursday (today is Saturday.)

I have upgraded to EasyBCD 1.7.0.1. I have installed GRUB from the Ubuntu CD several times. I have deleted and re-added the "NeoSmart Linux" entry a couple of times, both with and without the "No GRUB in the partition" box checked. If I delete and add the Linux entry the pulldown list contains an entry for "Linux live partion" (maybe not exactly, this is from memory) which I select. Later, though the Drive is set to C:.

The only difference checking "No GRUB" made was I get a screen saying "GRUB4DOS 0.4.3 ..." and a GRUB>_ prompt. Of course at that point "find /boot/grub/stage1" returns file not found.

I am stuck. Where is this chain broken? Could a new BIOS do this?
 
#2
^ Hello Ray!

um, well, ... idk know, im not the expert here lol sorry

but welcome, help should be on its way, if not today (its late for Computer Guru now (its 5:07PM CST) and he lives in GMT +3 or 2 i cant remember, but thats a few hours ahead of me lol)

tomorrow he will im sure address this problem promptly ^_^
 

mqudsi

Mostly Harmless
Staff member
#3
Hi Ray, welcome to NeoSmart Technologies.

Has your partition structure on the laptop changed? Or is Ubuntu still on the same drive/partition number (and order) as it was before?