Cannot load Ubuntu (Vista+Ubuntu 8.04 dualboot)

#1
The Vista option still works as usual, but the added option to boot into Hardy Heron leaves me with the following message:

BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant BootPart
Loading new partition
Bootsector from C.H. Hockstatter
Cannot load from harddisk.
Insert Systemdisk and press any key


I followed the instructions to place GRUB on the Ubuntu partition, which SGD displays as hd1,2. Likewise in EasyBCD, the Ubuntu part I added has the corresponding partition chosen (it shows it as the right size and that its Linux Native).

Some help from the experts would be appreciated. This will be a lifesaver if it can work, because GRUB does not see my fakeRAID and would require a bunch of work in order to add Vista to that.

In case you're curious, I have one 320GB drive (which is what Ubuntu is on, the third partition of it) and 2x500GB drives in RAID0 via the motherboard BIOS. Vista is on the RAID. In EasyBCD the 320GB drive is shown as Drive 0 and the RAID as Drive 1. SGD and Ubuntu list them in the other order, though, so I'm wondering if the problem is rooted in there somewhere.


update: So I changed my boot order to see if I could just get to Ubuntu that way. GRUB works, but I get an error saying it couldn't find whatever, but dropped me back to the GRUB menu anyways. Editing one of the boot lines to be hd0,2 instead of hd2,2 (I think that's what it was) made it boot correctly. Not something directly related to the issue above, and I can fix this. Just noting it here.

Update2: It seems that was in fact directly related to the original problem. Fixing GRUB results in the "press any key" prompt above actually telling me to press ESC to show the GRUB menu (for some reason its hiding by default?). Doing so shows the menu and it boots right. I'm still interested in making this work how it should without the error, but if we can't I'm not too concerned because everything does work.
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
Okay remove the Linux entry and add it again but this time check the box that says GRUB is not installed to the MBR.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
That is a way to get around GRUB not being installed correctly to the Master Booter Sector. Using that method tells me that GRUB was not installed to the Ubuntu drive as explained in the Wiki but installed to the boot drive. :wink:
 
#7
Well it was installed on the Ubuntu partition according to the Ubuntu installer. Probably some conflict with the drives being detected in the reverse order between Ubuntu and everything else.
 

mqudsi

Mostly Harmless
Staff member
#8
Yeah, it was as a result of a number of posts here where I'd walk the users through the setup procedure and it would still not be installed on the right partition for some odd reason that I added that feature to EasyBCD in the first place. Don't fret over it, it's most likely nothing you've done wrong.
 
#9
Hi, I have run into the same problem and tried to uncheck the "grun not installed to mbr", when choosing Ubuntu from list I am forwarded into a black screen that looks like a command line program, I am very new to linux (which is why I am practicing with ubuntu) and dont know what to do, I mean I'm not getting the error anymore, but I dont know what commands to input to boot now.

Any help is appreciated.
 

JustinW

Super Moderator
Staff member
#10
It is actually the opposite. You want to make sure the box is checked when adding the entry as this seems the only way for most to get it to work.

If it still does not work, re-install Ubuntu, recover the Vista bootloader from Vista's DVD, and then re-add.
 
#11
I read some other threads with similiar issues and tried something that worked for another guy that had a similiar set up to mine (2 sata drives), I switched the sata drives around, re-installed, and now it works fine. i don't know if its because my bios seems to think SATA 1 is the "boot" drive, or not, but vista was on SATA2, when I put vista on sata 1 and the second drive with all my other OS' on sata 2, everything seems to work fine, I just reinstalled ubuntu, logged into vista, added bcd entry, and it can boot into ubuntu fine.
 

JustinW

Super Moderator
Staff member
#12
That makes sense. Sometimes the BIOS and OS(es) see the drives differently regardless of thier physical setup. Anyway, glad you got it working and welcome to NeoSmart Technologies. Feel free to stop by the Introduction Thread and introduce yourself.
 
#13
Confused triple booting xp 64, vista 64, linux

Hi, I am currently triple booting with xp 64, vista ultimate 64, and linux. I have had xp and vista working for a while now and want to put Ubuntu on it too.

I tried everything, when i check "isn't installed to the bootsector" i get the GRUB bootloader

GRUB4DOS 0.4.3 2007-06-14, Memory: 636K/3581M, CodeEnd: 0x3EF2C 0
a box that has in it that has
Ubuntu 8.04.1, Kernel 2.6.24-19-generic
Ubuntu 8.04.1, Kernel 2.6.24-19-generic (recovery mode)
Ubuntu 8.04.1, memtest86+
Other Operating systems:
Windows vista/longhorn (loader)
Windows Vista/longhorn (loader)

when I click Ubuntu 8.04.1, kernel 2.6.24-19-generic
I get
root (hd2,1)
Error 27: No such partition
Press any key to continue...

and it takes me back to the menu

and then when i uninstall it and get BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant http://www.winimage.com/botpart.htm
Loading new partition
Bootsector from C.H. Hochstatter
Cannot load from hard disk
Insert systemdisk and press any key


I have 3 hard drives 1 with vista and one data drive and the other is a split hard drive with 3 partitions one for xp and one for ubuntu and the other is the ubuntu swap partition.

XP was installed first on drive c
Vista installed second on drive D
ubuntu is on XP resized by Ubuntu installer
 

JustinW

Super Moderator
Staff member
#14
Welcome to NeoSmart Technologies.

When booting Ubuntu, use grub's edit feature to change x in (hdx,y) to 1 or 3 (since you've already tried 2) until you get Ubuntu to boot. Then you'll need to make changes to grub's configuration file in order to save this change for future booting. To do this:

Open a terminal and issue the following command:

Code:
sudo gedit /boot/grub/menu.lst
Upon authentication, it'll open grub's configuration file in a notepad like program known as gedit. You should then change all of Ubuntu's entrys on the root line to match the correct number for x in (hdx,y).