Can't boot after Cloning

#1
After cloning a W7 OS HD I get a "missing NTLDR" message. There are some complexities here for which I could use some input.
First: This is a dual boot XP/W7 system. XP was installed first and resides on Drive 0 (HBA 0 on the system board). W7 was installed after and resides on a drive in position as Drive 3 (HBA 3 on the system board). In the bios I changed the boot order so it would see Drive 3 first, followed by Drive 0. Normally then Drive 3 is assigned as "C" and Drive 0 as "D". System worked fine. Now it gets a bit complicated. I had a failing Dive 0 which was an SSD of 128 GB. I replaced it with a Seagate ATA Drive of 250 GB. When I restored the original 128 GB image made from Norton Ghost 15 to the Seagate 250 GB I told it to "expand" the drive, thinking that I would get all the space but instead it made two partitions and put the 128 GB image on both!. Well it still boots fine but now I have an extra "H" drive on the second partition of Drive 0. I wanted to get rid of this, but before I did anything stupid I decided to clone the Drive 0 disk again (the one with two partitions that works), this time using Acronis True image, to another Seagate 250 GB drive, "just in case" things went south". Lets call this drive Seagate 2 After successfully cloning, I deleted the extra partition on Seagate 2 and expanded the first partition, which was marked as "active" by Acroins during the copy. I then switched out Seagate 1 (the one with 2 partitions) for Seagate 2 (one partition) putting it exactly in the same location as Seagate 1, in Drive 3 (HBA 3 on the system board). When I tried to boot I got the "missing NTLDR" error. (Note I get the same results even if I don't delete the extra parttion). I then tried several things:

1. Neosmart Repair disk-made repairs; when rebooting-all I got was a blue screen like the one before going into W7 but no long in, no animated "starting Windows" before hand.
2. Tried the W7 recovery disk- It located only the W7 OS but now on labled Drive F-it made repairs too but still got the Missing NTLDR"

My suspicion is that the Drive that has the W7 on it is marked as active and since it is first in the boot order its looking for NTLDR there instead of Drive 0; or that the drive identifier is wrong. When its all working properly, Drive 0 the XP drive is marked as "system" and drive 3 (W7) is marked as "boot".

So if I am not changing anything on Drive 0, why is this not working. If I simply put the old HD back in (Seagate 1 with OS W7 and 2 partitions)-everything returns to normal

Is there a way to run BCD from inside the neosmart recovery environment so I can see what is going on?

Incidentally, I really would like to simply do away with XP at this point but I am afraid of screwing things up even further unless I can fist get this to work,

I have read the forums, and tried to apply the knowledge to my situation but can really seem to step through this and could really use some help.


Thank You
 

Terry60

Knows where his towel is.
Staff member
#2
An NTLDR missing message tells you the PBR is looking for the XP loader instead of the W7 bootmgr.
That would suggest that the clone you did to "seagate 2" didn't update the PBR which still contains the remnants of an earlier XP existence, which implies that the Norton copy included the PBR but the Acronis did not. (or that seagate 1 had already been formatted under W7)
 
Last edited:
#3
Seagate 1 had been formated under Windows 7. So how do I fix this? How can I make Seagate 2 with its one partition work in this system. If I understand things correctly, the MBR resides on the HDD in Drive 0; in this case the drive with XP installed. Its supposed to load code from the active partition, which is the one marked as "system" and that in my configuration is Drive 0 as well. Then its supposed to run the boot manager in its root. And heres where I get fuzzy. NTLDR is on the Drive 0, in the root; I can see it, so what do I do now since when I have the clone in, I don't even get a boot menu-it just goes straight to missing NTLDR?
 

Terry60

Knows where his towel is.
Staff member
#4
The MBR isn't part of any partition. It sits at the front of the HDD before all of them and describes where they all are and which one is active. (see here) (sorry I mistakenly referred to the PBR as MBR previously)
If you format seagate 2 partition under W7 before you start installing things on it, you'll replace the PBR with a BCD compatible version.
 
Last edited: