Can't boot from ISO

#1
Hi. I just started using this program and i tried the boot from ISO function i must say that is a very handy function and fantastic if it works (never seen any other program do that). But when i tried it on an OSX86 (not linux) installation DVD it gets added to the Windows 7 boot menu and what not but when i select it from the bootmenu it dosen't boot up it just comes up with the GRUB4DOS command line with no error messages and nothing. I tried to type BOOT on the command line but it just said kernel need to be loaded first. Some help would be appreciated! Does GRUB4DOS support OSX at all? Is that why it dosen't work?

Thanks!
 

mqudsi

Mostly Harmless
Staff member
#2
NeoGrub is loading the entire image into memory.

1) This takes a long time
2) This may not work if you don't have enough memory
3) This isn't recommended for big files
 
#3
Thank you very much for your reply. I understand that it will take very long time etc... But i know it ain't loading it into the RAM since i see no hard disk activity at all... And it is fairly large (over 3GB). Is that why it dosen't work? And i have enough RAM (4GB).

Addendum:

:booyah::tongueout:oint:

Addendum:

:brows::tongueout:oint:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
oh!

I misread your post, I was under the impression that it was "stuck" and not at an actual, usable command prompt. Indeed, if you can type anything in then it's definitely not loading the image to memory.

What EasyBCD build are you using?
 

JustinW

Super Moderator
Staff member
#5
This features good for small diagnostic utilities like memtest86, not for complete operating systems. At 3GB even if you do have more memory it could take as much as 5 minutes just to load itnto ram, so you're best just using a disc or extracting the ISO to a hard drive partition and booting that way.
 

mqudsi

Mostly Harmless
Staff member
#6
Actually, it'll probably take even longer than that. It's not the fastest code in the world...
 
#7
Ok! Thank you very much both of you for your replies. Guess i'll just go for the simple option then and burn it to a DVD. BTW, i am using latest BETA build.
 
Last edited: