Can't boot into XP

Can't boot into XP with 6 disks in AHCI mode

I am trying to dual boot Windows Server 2008 (2k8) and XP. XP was installed first and was running fine in bios AHCI mode after I updated the drivers. I then installed 2k8 to another disk leaving the XP disk first in the boot order so it got the BCD placed on it and I could dual boot XP and 2k8 just fine. Since the XP system may eventually go away, and I don't want 2k8 backup and recovery dependent on the XP disk, I moved the BCD to the 2k8 disk and made it first in the boot order and 2k8 boots just fine but I can not boot XP any longer.

When I select XP as the choice, the machine just restarts the boot process again. I have tried lots of things to allow booting XP from the 2k8 BCD menu but just cannot make that work.

My goal is that I would like to either 1) modify boot.ini to also boot 2k8 as a choice or 2)
modify the BCD to boot XP as a choice. Here is where I am...

I have 6 disks total on 2 controllers both set to ahci mode.

4 sata disks are on an intel ICH10R and show as scsi in 2k8 and the 2 ide disks are on a gigabyte/jmicron controller and also show as scsi apparenly this is common in AHCI mode.

I can put the xp disk first in the boot order and 2k8 second and XP boots just fine and shows me the boot.ini choices and will boot into xp but not 2k8 which essentially complains about an improper bootstrap though I forget the exact msg.

I can put 2k8 first in the boot order and XP second and I get my BCD system prompts and 2k8 boots just fine but if I select the xp choice, the machine alwys reboots from scratch again with no messages or complaints.

If both controllers are in AHCI mode, and if I have 2k8 first and XP second in the boot order, and boot the 2k8 setup disk and go into repair, and do "bootrec /RebuildBCD", bootrec does not find the XP system, yet I can access the XP disk as the D: drive just fine. I have done bootrec /fixmbr and /fixboot and the BCD shows as fine with bcdedit and has the XP legacy entry which is left over from the original BCD that I moved off the XP disk when 2k8 was first installed. I have changed the BCD partition entry to point to D: which is where the XP disk appears under 2k8.

I have verified all the proper XP files are in the root folder though I have taken ownership of some of them from the 2k8 system in order to be able to edit and swap them around but I should not think ACL's are the problem during bootstrapping. I have set the boot.ini permissions back to +s+h+r in case that mattered as well as the other appropriate permissions for any other files.

Another clue is that originally, when the BCD was on the XP disk, the 2k8 disk management snapin showed that the XP disk partion had a "boot" status which it no longer has though it does show D: as active and primary. At one point, I put the XP disk into IDE mode and booted the XP setup disk into repair mode since XP setup will not run if the bios was in ahci mode for that controller asn XP did not originally support AHCI. I did make sure the MBR and PBR were there using the fixmbr and fixboot commands. And it indeed XP boots just fine and shows it's boot.ini menu but only if first in the boot order whether IDE or AHCI mode on the controller.

I suspect the problem has something to do with the fact that I have 6 disks across 2 controllers and the XP IDE boot disk is numbered SCSI-4, or the 5th disk, when I look at the disks in the bios and so is too far down the int13 chain for XP boot to work OK unless set as the first disk? Putting the XP disk second in the boot order and changing bios to have a second boot disk does not seem to affect the behaviour as I was hoping.

Another Catch-22 is that if I set the gigabyte/jmicron controller to IDE mode, then 2k8 does not see the IDE disks at all as apparently the jmicron controller is not compatible with the stock IDE drivers and I get an error trying to install the jmicron IDE drivers on 2k8. I ahve seen lots of complaints about the jmicron hardware and drivers but that is the only IDE contorller I have on the EP45-UD3P gigabyt board which otherwise is great.

Might it do any good to add the "osdevice" and "systemroot" values to the BCD for XP? I have not seen them in any dual boot examples.

Would it be posible to somehow modify the boot.ini file for booting 2k8? I did not see any options that might help except possibly /hal= and /kernel= and those values and the system root of windows are the same between XP and 2k8 anyway so I'm thinking it would not be possible to boot 2k8 from the XP bootstrap process.

Any other ideas on how I could or why I can't boot into XP from the 2k8 bootstrap process?

Or how I could get 2k8 to recognize the IDE drives?

Or how I can get this IDE drive to be one of the first 4 physical hard drives? Making it second in the boot order does not seem to cut it!

Thanks for any ideas. This has apparenlty become a challenge to me at this point! Dave
Last edited:
Get the [thread=642]easybcd beta[/thread]. Install EasyBCD in 2k8 and add an entry for XP.
Thanks and I wish it were that easy. Of course I did install EasyBCD and the entry for Xp was already there from my having moved the BCD. Nonetheless I deleted and re-added with EasyBCD who changed the {legacy} id to the XP guid.

Here is what I have in the BCD:

C:\Windows\system32>bcdedit /enum /v
Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
path \bootmgr
description Windows Boot Manager
default {009bede5-050a-11de-872d-f40a71c7659b}
displayorder {009bede5-050a-11de-872d-f40a71c7659b}
timeout 15
resume No
Windows Boot Loader
identifier {009bede5-050a-11de-872d-f40a71c7659b}
device partition=C:
path \Windows\system32\winload.exe
description Windows Server (R) 2008 Standard
osdevice partition=C:
systemroot \Windows
resumeobject {718b48bf-04f1-11de-93ab-806e6f6e6963}
Real-mode Boot Sector
identifier {009bede6-050a-11de-872d-f40a71c7659b}
device partition=D:
path \NTLDR
description Microsoft Windows XP

And here is what is on the D: drive:

D:\>dir /ahsr
Volume in drive D is I0_Boot_XPSP2
Volume Serial Number is 0478-7084
Directory of D:\
02/28/2009 03:52 PM 280 boot.ini
06/30/2002 12:25 AM 0 IO.SYS
06/30/2002 12:25 AM 0 MSDOS.SYS
08/04/2004 07:00 AM 47,564 NTDETECT.COM
08/04/2004 07:00 AM 250,032 ntldr
5 File(s) 297,876 bytes
0 Dir(s) 56,199,663,616 bytes free

D:\>type boot.ini
[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="XP Pro" /fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows Server 2008" /fastdetect /NoExecute=OptIn



Actually, I just noticed you said "beta" and that it is newer than the one I am using. Are there new features that might help this situation? Where are the features in 2.0 build 53 listed? Thanks, Dave
Last edited:


Mostly Harmless
Staff member
Tools | Auto-configure boot.ini in EasyBCD 2.0 beta.


Super Moderator
Staff member
And if that don't work, copy over to 2k8's partition. Should work just fine after that. The beta's got the auto-config feature CG's describing. The 1.7.2 release doesn't.
Last edited:


Knows where his towel is.
Staff member
"I have verified all the proper XP files are in the root folder"

You do mean the 2k8 root, don't you ? (please read point 3 in the sticky)
Your BCD entry shows ntldr on D.
It should be on C.
The 3 XP boot files should be on the same drive as bootmgr and the BCD. At the partition root, not inside any folder. Then the C:boot.ini points back to XP
No. boot.ini cannot be used to boot newer OSs
Last edited:
Most excellent. Works great now! Thanks to everyone. I even put my XP disk back in the natural order and boot.ini is referring to it as rdisk(4).

I understand how the boot sequence works now with everything on the 2k8 boot drive but have to confess I thought that pointing the BCD to the XP boot disk (2k8's D: drive) and referencing ntldr from there should have worked also as it seemed a natural handoff from booting one disk and then chaining to the bootstrap mechanism of the other. Guess I'll have to read about the process a bit more.

Bottom line is everything works great now and I can even move the XP disk to the first in the boot order and that works as well since I left the bootstrap files on the XP disk as a backup precaution.

And thanks to Mahmoud for having this website adn EasyBCD!