Can't boot Ubuntu

#1
I originally had BCD dual-boot Win 7 + Ubuntu working. Then yesterday it stopped working. When I choose the Linux entry in the boot menu, I get the Grub> command prompt from Grub 4 Dos that I can't do much with.

Here is what worked:

HD0:

MBR
Windows System Reserved Partition (/dev/sda1)
Windows 7 (C: drive, /dev/sda2)
Unallocated

HD1:

OSX System Reserved (hackintosh, not working)
OSX (not working)
Unallocated
Grub2 (ext4, aka D: drive, /dev/sdb3)
Ubuntu 10.04 LTS (/, aka E: drive, /dev/sdb4)
Swap
Unallocated

After I got it working, I deleted/renamed the drives D and E in Windows and added some more partitions. This is what it looks like:

HD0:

MBR
Win System Reserved
Win (C: drive)
NTFS (D: drive)

HD1:

MBR (Grub2 -- I had to reinstall this way so that I can boot Ubuntu from BIOS)
OSX (still in limbo)
OSX (still in limbo)
Unallocated
Grub2 again (tried Ext4 and BIOS Boot Partition, drive letter removed, later added back as U: drive)
Ubuntu 10.04 LTS (drive letter removed, added back as V: drive)
Swap
Unallocated
NTFS (E: drive)

HD2: (usb)

I and J drives.

I would hate to reinstall anything or unplug drives etc, since technically both Win7 and Ubuntu are working fine. They just don't want to boot from the same menu. (I also tried booting Windows from HD1's MBR Grub2 -- it tells me that I have a non-system disk on /dev/sda1. I suspect that's harder to fix).

If I could just tell BCD to find Ubuntu explicitly from HD1's mbr or hd(1,3)... Anyway, any help is appreciated.

BTW, I have reinstalled EasyBCD a few times, now on 2.0.2. Another suggestion: Is it possible to add a dry-run mode, where EasyBCD tries to figure out if each entry is bootable without having to reboot each entry and see what happens? Thanks.

- Phil (wufwuf)
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Phil,

Please download and try EasyBCD 2.1 beta from EasyBCD 2.1 Beta Builds - The NeoSmart Forums

With regards to dry runs - just create multiple EasyBCD Linux entry configurations at once, then reboot once to test which of them works.
 
#3
If the newer version of EasyBCD doesn’t fix the problem you’re probably going to have to reinstall Ubuntu. If you got it all configured and tricked out your going to want to backup your Ubuntu user data first. I don’t how to do that yet but if you go over to the Ubuntu forums I’m sure someone there will help you out.

After you reinstall Ubuntu you show no trouble adding it to EasyBCD.

http://ubuntuforums.org

Installation and upgrades


Regarding the hackintosh partition try the links below:

http://www.hackint0sh.org


http://www.hackint0sh.org/f181


General Macintosh support
http://forums.applenova.com
 
#4
I did reinstall

I did reinstall a couple times. Once with bootloader to /dev/sdb3 and 2nd time to /dev/sdb (MBR). After the second time, I also tried grub-install /dev/sdb3. I didn't use the --root_directory flag because my Grub2 partition itself contains no Linux image. Did I get that wrong? Will EasyBCD look for Ubuntu on /dev/sdb3 or /dev/sdb MBR? What if it finds both? I will try the latest beta this weekend. Thanks.

- Phil (wufwuf)
 
#5
The root directory flag “/”, a forward slash by any other name, needs to be in the partition in which Ubuntu is in.

I believe the normal procedure for installing Ubuntu and it’s Grub-2 loader to a second hard drive is to temporarily disconnect the first hard drive or hard drive zero. Normally you would assign the Grub-2 loader to the second hard drive itself “/dev/sda” but you can also assign it to whatever partition you have placed Ubuntu in. Then reconnect the first hard drive and the Easy BCD program should be able to allow you to add an entry for the Ubuntu on the second hard drive.

Like any multiple partition multiple operating system setup, messing around with adding and/or deleting partitions after you have OS’s loaded can be problematic. My personal belief is that it is probably best to get all your partitioning done first before loading operating systems. I usually set up whatever I can think of and then add an addition five spares. You can format the spares his fat 16 until needed in which case they take up about zero space if fully shrunk.
 
#6
Installing Ubuntu

The way the Ubuntu Live CD installs itself, you can put Grub2 in the MBR of any disk, or in any unmounted partition. It works pretty well whether you unplug any other drive.

The Hackintosh installer was a real nightmare. I had to unplug half my memory and all other drives. When I booted from CD, the machine had ethernet but no usb; when I booted from disk, it was the other way around. But I eventually got the machine to triple boot with 2 HDs using the Chameleon bootloader on hd1 withe everything working, except... When I wanted to increase the Mac's screen resolution, Snow Leopard died tragically beyond repair, and took Chameleon with it.
 
#7
I tried build 129 last night. Grub2 screen got stuck at "Starting cmain() ..." for 2+ minutes. So I turned off the machine and went to bed.

- Phil (wufwuf)
 
#8
I tried build 129 again. This time I do get the Grub4Dos prompt. I typed root (hd1,3), root (hd1,4), etc. It tells me that it could not find the partition. However, when I started Win 7 again, the partitions on hd1 all show up.

Did something screw up the GUID partition table on HD1? Is there a tool to check it and clean it up?
 

mqudsi

Mostly Harmless
Staff member
#9
If Windows can see it but Grub4Dos can't, then you didn't screw up the GUID partition table but rather the MBR one. Maybe.