Can't boot WindowsXP after a reconnection of the HDD

#1
Can't boot WindowsXP after a reconnection of the HDD


Desktop machine having 2 HDD's:
HDD one Hitachi SATA 2: 2 installations.
1.Windows Vista Home Premium 32b.
2.Windows 7 Professional 64b.
HDD two WD Caviar SATA 1: 1 installation.
Windows XP Professional sp2 32b.


Previous boot menu entry:
Windows XP Professional (check marked)
Windows 7 Professional
Windows Vista Home Premium


The cause of the problem:
Disconnected HDD two for testing another HDD.
Problem occurred after the reconnection of this HDD.


Current situation:
1. It takes 3 or 4 minutes to come to the boot menu after the start.
2. Windows XP Professional (check marked) does not boot.
3. Windows Vista and Windows 7 still boot but takes another 3 or 4 minutes to complete the booting.


Failed to add a new entry:
Have tried to add a new entry of the Windows XP but failed. A message says:
"EasyBCD failed to detect a valid installation of Windows NT - 2003 on all mounted drives and was unable to continue."


Help please.
How to reset the boot menu as it was before?

Thank you very much!
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
You probably have the BIOS HDD boot sequence wrong, Check that the Vista/7 Disk is before the XP disk.
If you have reconnected the HDDs on different channels than they were originally configured, you could have induced schizophrenia in your XP (thinks it's now a different letter than what's stored internally in its registry)
Goodells.Net :: Understanding MultiBooting
Make sure that you're reconnected to the same SATA channels as originally so that the PnP routines detect the HDDs in the same order as originally installed, and that the BIOS boot sequence picks the right one first. (It will reset itself as you disconnect drives and reboot)
 
#3
Thank you, Terry!

It is all right now.

Need your help for something else.
An extra option appears in the boot menu as the following:
Windows 7
Windows Vista
Windows 7
Windows XP

How to get rid of the extra Windows 7 ?

Thank you!
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
Just EasyBCD > Edit Boot menu > delete the one you don't want.
 
#5
The problem is that nowhere in the EasyBCD shows the extra booting option.
It shows only in the boot menu.
This is why I do not know how to get rid of it.
 

Terry60

Knows where his towel is.
Staff member
#6
Check that under Tools > Options you don't have "automatically load......." ticked (or the box above which accidentally got ticked instead on recent previous builds).
You might be looking at the wrong BCD if more than one exists.
 
#7
EasyBCD 2.1 Community Edition is installed on my machine.


Under Tools and Options, there are General Settings and Display Options. Under neither one could "automatically load......." or "Recent Previous Builds" or similar terms be found.


Only one EasyBCD exists in this machine.
 

Terry60

Knows where his towel is.
Staff member
#8
More than one BCD, not EasyBCD.
You can verify that you are looking at (and operating on) the correct BCD, by doing something trivial or cosmetic, like changing the name from "Microsoft Windows 7" to "My Windows 7" (highlight the entry and click on "rename" in the "edit boot menu" tab).
If the change appears in your boot menu and the "ghost" entry still exists too, then you can use
BCD Backup/Repair > Reset BCD configuration > Perform Action
Then add the W7 and XP entries again in "Add New Entry".
(Don't reboot until you've put some entries back in the BCD. EasyBCD will try to stop you if you do, but it can't prevent it)