Can't get EasyBCD to dual-boot 7 and debian

T

Tex

Guest
#1
Hi, I'm running easyBCD 1.7.2, and I'm having trouble getting it to dual-boot Windows 7 Ultimate x64 and Debian Lenny AMD64.

What exactly could be the problem? I reinstalled GRUB to the partition, but it's still not booting... It doesn't even display a boot menu...
 

Terry60

Knows where his towel is.
Staff member
#2
T

Tex

Guest
#3
I've installed 2.0 build 76 now, but I don't have time to reboot and work with it.

I'm assuming that by not deleting my windows 7 entry nothing can go wrong, right? I'll report back tomorrow if this works...
 
#4
Hi Tex,
If you format or delete your Debian partition before you replace the GRUB bootloader, then you just won't be able to boot into Windows. You will have to replace the GRUB bootloader with the Vista bootloader in EasyBCD or else you will again have to install your Debian distro to fix this error or re-install Windows 7.
 
#5
Hi Tex,
If you format or delete your Debian partition before you replace the GRUB bootloader, then you just won't be able to boot into Windows. You will have to replace the GRUB bootloader with the Vista bootloader in EasyBCD or else you will again have to install your Debian distro to fix this error or re-install Windows 7.
Guys: It is not clear whether he has Grub or the Windows bootloader installed to the MBR. He said he reinstalled Grub to the partition. He also said there was not a boot menu.

Based on the facts, I'd say he's probably using the Windows bootloader in the MBR, not Grub, but he can't get into Debian, using EasyBCD 1.7.2.

@Tex: What exactly have you tried? Why are you talking about removing the Windows 7 entry? What happens when you first turn on your computer? Do you go straight to Win 7 or straight to Debian without a boot menu?

Use the latest beta build of EasyBCD and add an entry under the Linux tab in the Add/Remove Entries section, selecting either Grub Legacy or Grub2 in the Type drop-down menu depending on which version of Grub Debian is using. If its Grub legacy, and you tried adding an entry that way (of course making sure to point it at the partition Linux is on under "Devices"), you can try adding the entry again, with the "Grub is not installed..." option selected this time, and it may work then.

Not knowing anything about Debian, that's the best support I can give at the moment on so little info...:brows:

Cheers.

Jake
 
T

Tex

Guest
#6
Hi, I'm using windows 7 ultimate x64 edition, I've got the windows bootloader installed to the MBR and GRUB installed to the partition I want to boot from. Nothing seems to trigger the windows 7 boot menu.

EDIT: Is there a button I can hold down? Or is it supposed to automagically pop up?
 
Last edited by a moderator:

mqudsi

Mostly Harmless
Staff member
#7
You need to install the GRUB entry into the Windows 7 bootloader with EasyBCD 2.0
 
T

Tex

Guest
#8
You know, I think I'm just going to install GRUB to the mbr. Not worth figuring this out.
 
Last edited by a moderator:

Terry60

Knows where his towel is.
Staff member
#9
No boot manager (not even grub) will display a menu if there's no choice to be made (only one entry).
Run EasyBCD and add an entry for your other system(s), and then the W7 bootmgr will present you with a menu.
 
T

Tex

Guest
#10
No boot manager (not even grub) will display a menu if there's no choice to be made (only one entry).
Run EasyBCD and add an entry for your other system(s), and then the W7 bootmgr will present you with a menu.
My current list:
There are a total of 3 entries listed in the bootloader.

Default: Windows 7
Timeout: 60 seconds.
Boot Drive: C:\

Entry #1
Name: Windows 7
BCD ID: {default}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Debian with neogrub
BCD ID: {6ac5b883-d180-11de-b04e-00241ddbcdb1}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

Entry #3
Name: Debian with grub
BCD ID: {6ac5b884-d180-11de-b04e-00241ddbcdb1}
Drive: C:\
Bootloader Path: \NST\nst_linux.mbr
have fun.
 
#11
If you have those entries, and your boot menu's not showing up, run this command from EasyBCD's Power Console in the Useful Utilities section:

bcdedit /set {bootmgr} displaybootmenu yes
 
T

Tex

Guest
#12
hi, it still didn't work. I'm just going to try and figure out how to get grub up and running smoothly.