Ci.dll error - startup repair not working

#1
My computer restarted by itself yesterday (got a feeling it was after an update). When it restarted there was a black screen with a Ci.dll error message.

I've tried the recovery disk that came with it but the startup repair seems to be stuck. I've let it run for over 12 hours and have restarted it again but still nothing is happening.

I cant get into safe mode, and if I try and run the recovery disc again it just goes straight into startup repair.

Any ideas?

Teresa
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Teresa, welcome to NST
The "repair startup" is for fixing the boot process. You appear to be getting further than that.
Try booting the Vista DVD, selecting "repair my computer", but then on the next page ignore "repair startup" and chose "system restore" and pick a time/date before the problem started.
 
Last edited:
#3
unfortunatley i cant ignore it - it just goes straight to it.
I've just downloaded the vista repair disc incase mine was broken - but still the same thing happens
 

JustinW

Super Moderator
Staff member
#4
You should be able to cancel out of that, either by a cancel button or an X in its window in upper right hand corner.
 
#5
I can get out of it - but as soon as I put the disc in again it starts straight away - i cant access the screen which will allow me to do a system restore