Configuring the BIOS to get EasyBCD to work

#1
After using EasyBCD to set up a dual W8/Linux boot, I got a blinking cursor when booting Linux. I then enabled "boot from external device" in the BIOS and now it works.

Does the solution make sense? Is such a setting required to allow require booting from a non-MBR partition? Are there similar BIOS settings required to allow EasyBCD to work? I'm glad it's working, but I want to make sure I understand in order to avoid future issues.

Details: I have Sony Vaio VPCSA3AFX with Windows 8.1 Pro on one partition and Scientific Linux 6.5/GRUB 0.97 on the other. GRUB was installed onto /boot during installation.

Help appreciated, thanks!

 

mqudsi

Mostly Harmless
Staff member
#2
My original thought was that Secure Boot was enabled by your UEFI firmware, and that enabling the boot from external devices feature was deactivating it allowing you to boot into Linux via EasyBCD.

However, I don't think that is the case as I don't think you're using the EFI boot loader in the first place. Can you post the output of EasyBCD's "Detailed Mode" with the BIOS setting set both ways?
 
#3
My original thought was that Secure Boot was enabled by your UEFI firmware, and that enabling the boot from external devices feature was deactivating it allowing you to boot into Linux via EasyBCD.

However, I don't think that is the case as I don't think you're using the EFI boot loader in the first place. Can you post the output of EasyBCD's "Detailed Mode" with the BIOS setting set both ways?
After swapping my hard drive for a new SSD and reinstalling W8+Linux, EasyBCD now dual boots perfectly, both with the BIOS "boot from external device" setting enabled and disabled. The "detailed" EasyBCD settings appear to be the same in either case. Let me know if you'd like more info, but it sounds like this was just a weird issue with my previous hard drive. Note that my BIOS does not have a UEFI/secure boot setting.