Connection doesn't have a valid IP configuration (wired)

#1
Hello,

Have an infuriating problem at the moment. I have a dual-boot set up with Windows 7 Ultimate and Windows 10 Pro 64-bit, and a Netgear N300 (DGN2200v3) modem router but wired-up. Using Windows 10 I can get connect to the internet but not with Windows 7 - which is my primary system, with everything setup and configured the way I like it, and so on. I lost my W7 connection when I uninstalled a free firewall (Comodo? ZoneAlarm?) which was causing me problems.

Now, when I diagnose the problem, I get the message: 'Local Area Connection 2 doesn't have a valid IP configuration" (also had messages about "verify local network adapter" and "reset the local area connection"). Under 'Network connection' settings, it says my broadband is "disconnected" - but when I click 'connect', it whirls around for quite a long time then I always get a message about "the modem has reported an error ... Error 651".

Naturally, I've Googled around - and looked at the existing threads on this very forum about this problem - but so far nothing has worked. Any ideas?

My Specs are: Intel Core2 Duo E6750 \ Abit IP-35 Pro \ 4gb Corsair Twin2X2048 XMS Xtreme Performance (800mhz) \ Gigabyte Windforce GTX660 2GB OC \ Sound Blaster X-Fi Xtreme Gamer \ Corsair HX 620w PSU \ Samsung SpinPoint 2TB \ Antec 900 Ultimate Gamer \ Arctic Cooling Freezer 7 Pro \ Samsung Writemaster SH-S223Q \ Acer 24" X243H

Thanks,
DANNY O'DARE
 

mqudsi

Mostly Harmless
Staff member
#2
Right-click your network connection and click properties, and disable any network filters not installed by default. You can try leaving only IPv4 networking enabled - that should do the trick.
 
#3
Thanks, but none of the above worked. I always get the same messages - "Unidentified network - public network", "no internet access", "Rest the Local Area Connection 2", "Local Area Connection 2 doesn't have a valid IP configuration" and "Error 651".

Driving me nuts!