Copy/Paste Not Working, Even In FireFox


New Member
I just posted this at
But after reading more carefully here and on the bugzilla,
I found out that that bug I'm refering to in my post - which has been fixed
- that fix is already be implemented into FireFox, which I use.
So, I decided to try to post it here, too, since it was you that made the developer team fix
one of the copy/paste bugs.
Also, I have added a bit more info in this post, which I have discovered after I posted at bugzilla.


I used FireFox 1.0.7 until just 4-5 days ago, and I never had the copy / paste problem there.
However, at June 05, 2006, I uninstalled it and installed instead, and then I got it.

When it happens, I can fix it temporarily by using one of two quick tricks;

Trick #1. Pressing ALT + TAB twice.
This changes from the "bad" FireFox window to another window, then back again, and now the FireFox window is working again.
The only times that this would not work was if I had just that one window,
but I usually have a lot of windows - especially since I don't use "tabbed browsing"
Also, since the error happens under a copy/paste operation, I usually copy from one window and paste into another window..

Trick #2. By minimizing, then restoring the FireFox window.
This is not as quick as quick as trick #1, but it is still pretty quick when I do it with keyboard shortcuts;
Press and hold down ALT + SPACEBAR, then press "N", then "ENTER", then release ALT + SPACEBAR

I have read about the Adware.Advertmen - the "pushow**.dll"
and I don't have this or any other trojans, ad/spywares or rootkits on my pc.

My question is this..;
I have read that there are more than one copy/paste bug,
and also that - if I understood that correctly - at least one of the bugs already *have* been fixed.
Can anyone tell - from my description of it - if the bug that *I* have is fixed?
And - if so, is there any update I may apply, or some patch I may use?

When I tried to follow the link about the fixed bug, I came to just a code snippet for nsClipboard.cpp :frowning:

One of the comments there is a bit like my bug, in that "minimizing, then restoring" trick work,
but for him, only CTRL + C or CTRL + V stopped working, the right-click context menu would show Copy/Paste.
This is different from my bug.
For me, neither CTRL + V, nor right-click -> Paste, nor selecting from FireFox menu Edit -> Paste will work.
CTRL + V doesn't do anything, and the "Paste" selections are greyed out.

I also noticed:

If I first copy from one window, then open a new FireFox window to paste
- if that window is "bad" and not possible to paste in,
then if I open yet another new FireFox window, that one will *always* also be "bad".
So this seems as the only "reproducible" thing I can see in this bug.

I often have 10 - 15 FireFox windows open at once, and as far as I can tell, the "bad" window effect only spreads
to *new* FireFox windows, those that I open *after* I have first got the error in one window.
I have not (yet) seen the error being spread to windows that I have opened earlier, *before* the "bad" window became "bad".

And finally:
When one FireFox window has become "bad", and I open another one (which as I said,
is *always* also "bad"
- I notcied something strange just now:
My start page is Google search, or rather, advanced search, with english language (not my native)
If I try to paste into the "with all of the words" field, when I right-click, the pop-up context meny has "Paste" greyed out.
If I - however - try to paste an URL address into the address field on the Navigation Toolbar,
the "Paste" selection on the pop-up menu is *not* greyed out..! But, if I select it, nothing happens.
Also the other selections - "Undo", "Cut", "Copy", "Delete" and "Select All"
- none of them are greyed out, but none of them are working - nothing will happen when I select them.

Also, I read something about the mouse's scroll-wheel, that it too should stop working,
But that is working for me.


I have "Winternals Administrator's Pak" installed,
with "Filemon Enterprise Edition", "Regmon Enterprise Edition", and I have Sysinternals free
"Process Explorer" and "Diskmon"

As I said - when I first get the "bad" window error, any new FireFox window I open after this,
while "Firefox.exe" is still in memory - will also be "bad".
My idea is to run any / all of these programs,
and try to see just what happens when I make the windows "good" again,
either by the "ALT + TAB, ALT + TAB" trick, or the "minimize, then restore" trick.
If I just log it, and afterwards log a "normal" "ALT + TAB, ALT + TAB" operation
or a "normal" "minimize, then restore" operation
- i.e. on a FireFox window that is already good from the beginning..
..then I should be able to spot the differences..
I hope!
Hello quantel and welcome to NeoSmart!

That's an awesome bug report you just wrote, very impressive.
I'm not the expert here, but have you tried renaming firefox.exe to something else? I realize you said you weren't infected, but it just takes all of two minutes, no?

One more thing, you say "when it happens," I assume this means that it's not a regular bug and doesn't happen every time you turn on FF?
Hey quantel, glad to see you made it online...

As jane said, that's an amazing report, two thumbs up!

The thing is, I know exactly what you're talking about: I've seen this bug before, the last time was in FF Right now I'm actively testing and developing for the new (much improved, with ActiveX security modules) IE7, so I haven't run in to this bug since we started the patch for it.

There are two things I can think of:

One, as you suggested, is that you have a second or third or even fourth C&amp:tonguewink: bug that hasn't been patched, but I don't think so, since all C&amp:tonguewink: actions refer to the cpp file that was patched. At any rate, it doesn't sound like the C&amp:tonguewink: core has issues, it seems that somewhere before C&amp:tonguewink: is called on you're browser is going bersek.

As such, I can only think of two things you might want to try to verify this before we start digging into the core:
  • Backup and delete your existing profile. The profile is stored in the \Documents and Settings\USERNAMEHERE\Application Data\Mozilla\Firefox\Profiles directory. Please back it up, it may be a lead!
  • If that doesn't work, please upgrade to Bon Echo Alpha 3 and tell me if you're still experiencing it there.
If the profile trick works, please, please, open up the old profile, clean it of any sensitive data, history, passwords, etc. and email me a copy at, because this is an outrageous bug that must be fixed ASAP.

Using Firefox in Kubuntu 6.06, I had the same problem: no middle-mousclick paste in form fields. Until now I used the KDE klipper applet to force the mouse buffer in the kde/firefox (?) pastebuffer, after which I could use the trusted ctrl-v .

Just today I changed the klipper options from 'Separate clipboard and selection' to 'Synchronize contents of the clipboard and the selection' and all my cut&amp:tonguewink:aste problems have disappeared.

Hope this helps anyone...

Hello Peter, and welcome to the NeoSmart Forums :smile:

We've made note of your fix, as a matter of fact, that opens an interesting line of thought for other operating systems as well, because quite a few programs tie in to the clipboard buffer (such as download accelerators that scan the clipboard for .exes for it to download, etc).

Most of the one's I've seen were well-written, but of course all it takes is one faulty line of code...

Thanks for dropping by, and doubly-so for sharing this tid-bit and hopefully it will come in handy to our members and guests.


(PS A link to your post has been added here: )
I have upgraded to Firefox on Windows XP Pro and I am still experiencing a cut and paste problem. The edit menu Edit->Copy is enabled, but clicking it doesn't work and Edit->Paste stays greyed out. The keyboard shortcuts CTRL+C and CTRL+V don't work either. As with other posts to this list, the problem is intermittent and appears to happen more often when I have multiple Firefox windows and tabs open. I also occasionally have firefox fail to respond to other SHIFT+ key presses, such as the UK keyboard shortcut for the inverted-comma, SHIFT+2.

I am running a 3GHz Pentium 4 with 1GB Ram, my Windows language and keyboard settings are set to English (UK) and I have the AdBlock and DOM Inspector extensions to Firefox installed. Firefox is commonly run along-side Outlook, MSN Messenger and Sophos Antivirus at minimum. My homepage is set to, and this is where the problem appears to most frequently occur, although I have experienced it on other pages.

I have checked for advertisemen and it isn’t on my system. As far as I'm aware I'm also free of any other nasties.
I have managed to repeat this problem by doing the following:

Open a copy of firefox from the start menu, enter some text and copy using CTRL+C
Open a second copy of firefox from the start menu, paste the text using CTRL+V
Open a third copy of firefox from the start menu, paste the text using CTRL+V.

Normally, on the third attempt, paste fails. Interestingly the failure sometimes occurs on the second attempt and very occasionally I can get up to 5 firefox windows before paste stops working.

I have asked colleagues to test this on their machines and they do not encounter the same issue, they can open multiple copies of firefox and copy/paste always works.

I am going to investigate further and will post any findings to this list.

If I select a "good" firefox window and return to a "bad" firefox window (do nothing else) and then try to paste into the "bad" window, paste fails.

However, if I select a "good" firefox window and return to a "bad" firefox window, CLICK THE BOX where I want to paste (despite it already having the text cursor in it) and then paste, paste works.
I reinstalled Firefox and the problem still occurs. But the new install has acquired all the settings from my old install, so I don't know whether there is a problem there somewhere.

Can someone tell me how to fully uninstall Firefox including all user settings, so that I can perform a proper reinstall?

Hey Andy, long time no see :smile:

Dinnertime - just wanted to let you know I'm not ignoring you :-D so don't feel left out :wink:

I'll post back shortly :smile:

1) Uninstall Firefox or Bon Echo or Minefield or whatever it is version of FF that you have running.
2) Go to 'C:\Documents and Settings\USERNAME\Local Settings\Application Data'
3) Delete the folder 'Mozilla\Firefox'
4) Go to 'C:\Documents and Settings\Computer Guru\Application Data'
5) Delete the folder 'Mozilla\Firefox'
6) Restart the computer for all pending deletions to take place.
7) Install the latest version of Firefox.

WARNING: You will lose all favorites, history, settings, customizations and more! NeoSmart Technologies does not take responsibility for damages incurred as a result of this action!
Wouldnt using a application like CCleaner also help out as that would clean out some of the registry keys that would be still around?