Create Bootable USB Stick: The boot partition must be a primary partition

Status
Not open for further replies.
#1
Hi

I'm new to the forums, been using EasyBCD for about 1/2 year now without any problems.

I am running EasyBCD 2.1.0.146 and trying to create a bootable USB stick with my boot info. The USB stick is newly formatted with FAT32, with only 1 partition. When I click "Install BCD", having the USB stick chosen as target, I get the error message
The boot partition must be a primary partition.
Please either select a different drive or convert the selected partition to primary first, then try again.
How would I convert the one and only partition on the USB stick to primary?

Thanks for your help
Beat
 

mqudsi

Mostly Harmless
Staff member
#2
It depends mainly on whether or not you want to preserve the data on there.
 

mqudsi

Mostly Harmless
Staff member
#4
WinKey + R | compmgmt.msc | Disk Management

Go to the USB drive, right-click on all volumes drawn for that device, and delete them. Create a new volume, and make sure you specify the type as "Primary"

Cheers.
 
#5
Thanks for your advice, but unfortunately, the option to delete the volume on the USB stick is grayed out, so I cannot delete nor create a new volume as primary.

I've found some articles on the internet that this could be related to an USB driver problem, but I have to investigate further. If you have an answer as to why the option would be grayed out, I'd be very thankful.

Beat
 

Terry60

Knows where his towel is.
Staff member
#6
Do you have "Readyboost" enabled ?
If the OS thinks it's a paging device, it won't allow format, delete etc.
 
#7
ReadyBoost is not enabled in Win7, and even on WinXP (where there is no ReadyBoost) I cannot delete the volume. I've also tried a different stick to no avail.

Beat
 

mqudsi

Mostly Harmless
Staff member
#8
Can you do this from another PC?
 

Terry60

Knows where his towel is.
Staff member
#9
The volume (partition) options are only available if there are multiple volumes and/or the filesystem is NTFS.
Format should be available.
 
#10
I somehow got it to work now. I plugged the USB stick into another Win7 computer and was able to install BCD from there. Then I went back to the original computer and everything worked out OK. No idea why that worked, but for right now it's OK for me.

Thanks for all the suggestions and help!

Beat
 

mqudsi

Mostly Harmless
Staff member
#11
Hey, you're welcome.
 
#13
I just had this issue, the steps above unfortunately did not resolve it. However, I did find the fix from the intel website,

  1. Attach the USB flash drive to the Windows 7 or Windows Vista system.
  2. Go to the command prompt (Start > Run > type cmd).
  3. When the Command Prompt Window opens, enter the following command:
    1. DISKPART and hit enter.
    2. DISKPART > LIST DISK and hit enter. (After you enter the LIST DISK command, it shows the disk number of your USB drive. Here the USB drive disk number is taken as Disk 1.)
    3. DISKPART > SELECT DISK 1 (If required, replace DISK # accordingly.)
    4. DISKPART > CLEAN
    5. DISKPART > CREATE PARTITION PRIMARY
    6. DISKPART > SELECT PARTITION 1
    7. DISKPART > ACTIVE
    8. DISKPART > FORMAT FS=FAT32 QUICK
    9. DISKPART > ASSIGN
    10. DISKPART > EXIT
Source: How to Make a Bootable USB Drive for Windows 7* Installation for...
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#14
As this is such an old thread, I'm locking it.
 
Status
Not open for further replies.