Creating a bootloader for a Removable drive to be used in multiple machines


New Member
Hi there. Only just getting my head around BCD world, and had a hunt of the forums but couldn't find anyone trying to do what we're doing, so here's a series of questions.

The plot
We use removable hard drives to deploy Windows 7 images out to client machines. The drive boots into WinPE, and by a method provided by MS SCCM it allows us to drop a new image over a client box. That works fine, but if the drive reboots back onto the removable drive as part of the installation it stuffs it up, so I'm looking for a method whereby if the drive is plugged into a client and the bios is set to automatically boot from the USB drive, it'll provide a menu & if no response is given it'll drop onto the client OS without amending anything.

The ideas
I'm presuming that I need 2 options in the boot manger, one being the 'boot' to USB drive one which is down as default (and works fine already), but the other needs to:
a)boot from the active partition for that machine into the host operating system (most likely Vista/Win7 but could be XP)
b)be able to handle multiple machines - so (I think) it can't have a fixed reference to a GUID of a drive, as this will be used on different machines, different hardware and so on.

I've tried a few different options through NeoGrub as I figure this seems to be the most 'flexible' of the options that EasyBCD allows for. However, I'm not really getting anywhere.

Also tried with 2 instances of the 'boot to windows', one pointing at C and one pointing at the removable drive which worked fine, until I move it to a different machine (presuming that's the GUID issue creeping in).

a) understand what I'm on about
b) suggest if it's evan possible
c) able to point me in the right direction please?


Hi Ash,

What you're proposing is certainly doable, but it's a bit complicated.

* Create a bootable USB with EasyBCD
* Add a NeoGrub entry to that USB
* Add an entry to the PE installer to that USB

Modify the NeoGrub entry to boot from the boot drive (use the chainloader+1 command), and make it the default.