Creating a Windows Vista Bootable CD with other files on it

#1
Vista Blue Screened with an UNMOUNTABLE_VOLUME error.
Not good I think.

I have the recovery disk etc and run repair. Same error. Try to reinstall and it can't find the drive so I'm thinking it's hardware on the WD 320 gig drive. Corrupt sector or something.

I get a new drive - reinstall vista and the new drive works great. There may be some data on the HD that was added between the last back up and the crash. Western Digital has a diagnostic tool here http://support.wdc.com/product/download.asp?groupid=608&sid=30〈=en

The tech tells me to burn the iso file using Nero as the Windows media player apparently doesn't do it. I do so and I can't get the disk to boot.

Here's my question, how can I effectively run a diagnosis on the HD to determine the problem? Is it best to slave it to the new drive and run it from Vista or does it need to be done from a boot disk? If so, how do I create a bootable Vista disk with the diagnostic utility on it? Or does it have to be a Vista boot disk - can I just boot to a DOS disk to run the utility?

Thanks in advance for your answers. Obviously I only know enough to be dangerous.
 

Terry60

Knows where his towel is.
Staff member
#2
#4
This error message is usually due to having a corrupt boot sector on the "system" partition.

Boot from the recovery disk, access the Command Prompt, and run the following commands:

Code:
chkdsk /r X:
replacing X: with the correct drive letter of your "system" and "active" partition (which is probably your Vista OS's partition, but not necessarily) as seen by the recovery disk. And that should fix the problem.
 
#5
Update: I downloaded Imgburn and successfully burned the ISO. I was able to run diagnostics on the disk. Thanks Terry

Not that these will mean anything because they're specific to WesternDigital hardware but the quick test reported error 0007 - Read element failure and the full test reported error 0225 "Too Many Errors Found".

I just love the fact that they have a code for too many errors. : )

Coolname - I didn't get to run check disk last night. I highly suspect it will show numerous bad sectors.

Moving forward to attempt data recovery. Mostly photos from a ministry trip. Last back-up was Sunday. Pictures transfered to the computer Monday. Crash was Tuesday.

*sigh*
<--- Hates HD failures.
 

Terry60

Knows where his towel is.
Staff member
#6
I hate to sound like a stuck record (is anyone here old enough to remember those round disks that stored music as a wavy line ? ), but I'll repeat my endorsement anyway.
I'm a great fan of the freeware EZBackItUp, which I use last thing every day to copy any new or changed files in my User folders and my Mail folder. It's a doddle to set up, and apart from the initial run (which obviously has to copy absolutely every user file), it's lightning quick.
Recovery of a lost or damaged file is a simple drag back to the main disk. (my backup is a separate internal HDD for security, and I also use the same program for monthly backups to an external USB disk)
It's a bit late for you now Rat, but in future you might benefit.
Remember Parkinson's Law "Anything that can go wrong, will go wrong".
 
#7
Good Point Terry... And I'm new here so it's not a stuck record sound.
I thought weekly BU's were enough... and normally it would have been... but photos can't be recreated.
I'll check out EZBackItUp as I'm looking for something better than the clunker that came with Vista.
 
#9
Have you tried my suggestion yet, and ran a check disk on the problem drive?
 
#10
Coolname007

Here's what I'm getting:
File record segment 44352 is unreadable.
File record segment 44353 is unreadable.
File record segment 44354 is unreadable.
File record segment 44355 is unreadable.
File record segment 44368 is unreadable.
File record segment 44369 is unreadable.
File record segment 44370 is unreadable.
File record segment 44371 is unreadable.
2 percent complete....
File record segment 56724 is unreadable.
File record segment 56725 is unreadable.
File record segment 56726 is unreadable.
File record segment 56727 is unreadable.
4 percent complete...
File record segment 103240 is unreadable.
File record segment 103241 is unreadable.
File record segment 103242 is unreadable.
File record segment 103243 is unreadable.
8 percent complete
File record segment 177412 is unreadable.
File record segment 177413 is unreadable.
File record segment 177414 is unreadable.
File record segment 177415 is unreadable.
File record segment 177416 is unreadable.
File record segment 177417 is unreadable.

And on and on.....
 
#11
Did it fix those problems though?
 
#12
Here's the more exciting stuff...

40 bad file records processed.
108 reparse records porcessed.
CHKDSK is verifying indexes (stage 2 of 5)...
10 percent complete.
Correcting error in index $SII for file 9.
Correcting error in index $SII for file 9.
An unspecified error occurred.

X:\Sources>

And it stopped... I'm restarting it now.

Hey - what's the dos command to browse the dirs on the disk?

I thought it was cd \ c: but that doesn't seem to work.
 
#13
Hey - what's the dos command to browse the dirs on the disk?

I thought it was cd \ c: but that doesn't seem to work.
Code:
cd /d C:
dir
 
#15
Thanks...
I'm re-running chkdsk and it's past the unexpected error and sorting indexes and correcting errors

*Crossing fingers*

Addendum:

chkdsk errored again but after much longer...
I'm going to try again.

In between runs though I did try cd /d C:
"The request could not be performed because of an I/O device error."

Restarting chkdsk.
 
Last edited:
#16
Yep, a definite problem with your boot sector like I originally suspected...
 
#18
Anyway around that to the data?
If you mean the file data stored on the partition with the corrupted boot sector, then no. Partitions are accessed through their bootsector (even if there is no boot code there), and so the data can not be accessed at all on a partition with a corrupted boot sector...hence why you need to repair it with check disk.
If its still not booting after that, then the problem could be the boot code. So next run this:

Code:
cd /d C:\Program Files\NeoSmart Technologies\EasyBCD\bin
bootsect /nt60 /force C:
Note that the first (and hence, the second...) command will only become available for use once the boot sector is repaired, because otherwise, it would not be able to browse the filesystem.
 
#19
No luck with that (Incorrect function)....

And now the chkdsk has stopped "Failed to transfer logged messages to the event log with status 50"

I talked to WesternDigital and apparently the HD is still under warranty so I'll get a replacement.
And I'm looking at better back up programs to run daily.

I have a 500 gig External where I back up but when I get my replacement HD I'll slave that to the current and back up daily - even to the external and odd days to the internal slave.

Thanks for everyones help!
 
#20