Default Boot to Win 7, not XP, 2 hard drives

#1
I have a Dell XPS 630. The new primary hard drive has 64 bit Win 7 Ultimate on it in SATA 0 and the old hard drive has 32 bit Win XP in SATA 4 (the DVD drives are SATA 2 & 3).

The computer will boot to the XP drive unless I press F12 during startup and select the Win 7 drive in the BIOS. (The Win 7 drive is Ch. 2 and the XP drive is Ch. 5)

EasyBCD is installed on the Win 7 drive and "Advanced Settings" shows Win 7 is on C: and XP is on F: which is correct. However by default the computer boots XP.

"Edit Boot Menu" has Win 7 checked as the default.

"View Settings" has the following:

There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 30 seconds
EasyBCD Boot Device: F:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Microsoft Windows XP
BCD ID: {9d1204c4-95e7-11df-ae9a-fc996bf08fbe}
Drive: F:\
Bootloader Path: \NST\ntldr

What am I doing wrong and how can I have the computer boot Win 7 by default?

There does not appear to be any way In the BIOS to tell the computer which hard drive to boot from. I have to press F12 during the boot process and manually tell it which hard drive to use.

Thanks in advance for your assistance.
 

Terry60

Knows where his towel is.
Staff member
#2
Phoenix Award BIOS (on my ASUS mobo) has a tree structure.
Ignore the HDD list on the default page which just describes the installed hardware details.
Navigate to the boot section in the top line
Top level of the tree defines the boot priority beetween hardware types (USB/CD/HDD)
Drill down in the HDD section and the sequence of HDDs can be set.
If Dell really don't provide such an option
a) write them a snotty email asking why not
b) try switching the SATA cables between the 2 HDDs
c) boot with XP disconnected so that the BIOS has to boot W7, then reconnect XP and the BIOS should have reset W7 by default.
 
#3
> If Dell really don't provide such an option
a) write them a snotty email asking why not

Yes, they certainly deserve it. The suggestion on the Dell tech support site is to use EasyBCD. I've scoured all the menus and the only option is to choose what type of device to boot from, with no option to differentiate between hard drives.

> boot with XP disconnected so that the BIOS has to boot W7, then reconnect XP and the BIOS should have reset W7 by default.

That's how I originally set up the system, but it keeps booting to XP.

Any suggestions of the EasyBCD settings?

Thanks for your input :smile:
 

Terry60

Knows where his towel is.
Staff member
#4
EasyBCD can't really help till you get to the W7 bootmgr.
You've got to get the PC to go to the W7 HDD first
What about option b) ? That should be foolproof. If the PC will only boot that SATA channel, put W7 there.
The only other way (I wouldn't recommend because it's so untidy and anti-intuitive) is to use EasyBCD from XP to "change boot drive".
That will copy all the W7 boot files across to XP and boot W7 via the "wrong" HDD.
Try switching the cables first.
 

mqudsi

Mostly Harmless
Staff member
#5
Terry, using "Change Boot Drive" from within Windows XP won't even work for him - it requires Vista/7.

CompNH, you'll have to do as Terry says and change the drives around.
 
#6
Thanks everyone. I changed the drives and it worked - should have tried the simplest solution first! I appreciate your time and knowledge.