Delete Windows XP Setup entry

klintel

New Member
Here's the issue:
I am running Windows 7. When I boot up my computer I get the boot menu for Windows 7 or Windows XP setup. Windows XP setup is a broken setup (missing files), and Windows XP is also set as the default OS. How can I delete the XP entry and just boot directly to Windows 7?

Here are is the ouput of bcdedit /enum

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {84bd1ec0-de20-11de-bc85-bf302483c12e}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 30
Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {bootloadersettings}
recoverysequence {84bd1ec2-de20-11de-bc85-bf302483c12e}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {84bd1ec0-de20-11de-bc85-bf302483c12e}
nx OptIn

and here is the boot.ini:

[boot loader]
timeout=5
default=c:\$WIN_NT$.~BT\BOOTSECT.DAT
[operating systems]
c:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"

Any help? Thanks.
 

SIW2

Member
1. Use Easybcd 2.0 to set 7 as the default.

Click Change Settings - then, under Global Settings, select 7 in the default drop down and click Save Settings.

EASY-GLOBALSETTINGS-2009-12-22_032653.jpg

2. Delete the XP entry.

Click Add/Remove Entries - then highlight the XP entry and delete.

EASY-ADDREMOVE-2009-12-22_032741.jpg
 

mqudsi

Mostly Harmless
Staff member
You may need to open Boot.ini and remove the entry from there.
 

klintel

New Member
Using Easybcd 2.0 beta:
There are only one entry in both the add/remove window and the default OS drop-down (both of them saying "Windows Vista"). When I got to edit legacy options I get the following:
;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=5
default=c:\$WIN_NT$.~BT\BOOTSECT.DAT
[operating systems]
c:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"

How do I delete the boot.ini file? I made sure all hidden files are being show but there is no boot.ini in c:\ , but for I go through the cmd prompt (as the admin), type c:\boot.ini. The boot.ini file comes up. If I type "del boot.ini" it tells me access is denied.
 

Terry60

Knows where his towel is.
Staff member
Make sure all 3 of these attributes are correct in folder options. Some files are "super hidden".
Try right click on Explorer, then select "run as admin" and delete it from there.
 

klintel

New Member
Terry60, I didn't have all 3 checked as you had suggested. No more boot menu, as I had wanted. Thank you for your help.
 

back2basics100

New Member
modify/delete boot ini xp

i als want to delete (xp recovery console) like user --->klintel
run bcd and cleaned recovery xp
i run win 7 home edition

but in boot it sees also recovery xp

bootloader like this:
Code:
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=0
default=c:\CMDCONS\BOOTSECT.DAT
[operating systems]
c:\CMDCONS\BOOTSECT.DAT="Microsoft Windows XP Herstelconsole" /CMDCONS
how can i modify/delete de boot ini.??


when i want to delete it access denied , only admin


im a noob, so can someone tell me step by step how i do that??


sorry about my language, im dutch ....

regards ricardo
 
Top