Deleted NeoGrub from list, cannot boot into 7

EL84

New Member
#1
===ERROR IN THREAD TITLE, SHOULD READ DELETED *WINDOWS 7* FROM LIST===

Hi there. Let me tell you what I was trying to do, and let me tell you what happened lol

I installed EasyBCD with the intent of removing the Windows bootloader, so that the Ubuntu-installed GRUB selection screen could be my only bootloader.

So from the entries screen, I left NeoGrub and deleted Windows 7. Restarted- and that was the worst thing I could have possibly done.

Now I restart and my GRUB shows up, I select Windows 7 at the bottom of the list on /sda1

Normally this would bring me to my Windows 7 launcher with a few 'extra,' 'dead' entries. But now, a few lines of code flash quickly then a grub4dos txt appears with some commands, which I know nothing about. I can type in help but it brings up a lot of commands that need triggers and that is the road block I am stuck @

So now I am on Ubuntu and that is all fine and dandy but I really want windows 7 back so that I can get my other work done. What are my options? And thank you so much in advance for your help.

Edit:
I have 3 partitions fyi
one is a fat32 data partition, one is a ntfs windows 7, and one is ext4- ubuntu.
 
Last edited:
#2
Hiya El84.
Sounds like you want to put Grub in control of the boot by placing it in the MBR.
Probably the easiest method to accomplish this is by using a Super Grub Disk.

You can also do it through the Ubuntu command-line if you like (while booted from the LiveCD in a "Try Ubuntu with no change to my computer" session):

sudo grub
(type password)
root (hd0,2)
setup (hd0)
quit
exit

From the sounds of it, your /boot/grub/menu.lst in the Ubuntu partition may be mis-configured however in the Win 7 entry there. If you want, go ahead and post the contents of that, along with the results of the following command run from Applications->Accessories->Terminal:

sudo fdisk -l

(the last letter is a lowercase "L")
 

EL84

New Member
#3
Thank you for the speedy help . Here is what the terminal gave back

skevin@kevin-ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x34623462

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3133 25165791 7 HPFS/NTFS
/dev/sda2 4701 7833 25165822+ 83 Linux
/dev/sda3 9015 19457 83883397+ b W95 FAT32
I tried the sudo command, it made me retype it a different way with the apt-get prefix. It asked me if I wanted to remove the old one and install the new version, I said yes. There was no time or option or place for me to type in those other things. Did I just mess it up for myself even worse? I'm afraid to restart and be left with 0 operating systems.

It's also worth mentioning I have no CD-Rom being that I am on a netbook
 
Last edited:
#4
Ok, sounds like you just installed Grub2.
Was that what you were using originally? Which version of Ubuntu is this? 9.10?

While you're there in Ubuntu, can you go ahead, and post the /boot/grub/menu.lst contents? Thanks.

Once you do that, go ahead and reboot and see if Grub was installed to the MBR or not.

If it was, you'll see the Grub menu first at startup, instead of the menu with the NeoGrub entry.
 
Last edited:

EL84

New Member
#5
Yes I was using a beta version though, I believe it was 1.97v of Grub. Ubuntu is the newest release with up to date packages.

I did not reboot yet and there is no file in the grub folder named menu.lst which leads me to believe it is yet to be created.

What I think happened was I installed a 'separate' "neogrub" via inside of windows while I was still able to run it and after that was implemented I deleted the windows 7 entry completely which deleted the boot loader screen all together apparently?
 
#6
Whoops...duh, I forgot. No menu.lst for Grub2. It uses a grub.cfg in the Grub folder.
Nevermind. Go ahead and reboot. And you're right, of course. That is why you can't get into Win 7 from Grub. Because Grub still chainloads bootmgr, which uses the BCD that no longer has a Win 7 entry in it, since you deleted it. Ok, so in that case, to get your W7 entry back, you can do it manually from the Command Prompt on the W7 DVD. Just boot it, select "Repair My Computer", then "Command Prompt", and run these commands:

bcdedit /store C:\boot\bcd
bcdedit /create /d "Windows 7" /application osloader

bcdedit should return the GUID for the newly created entry. Use it to replace "GUID" in the following commands:

bcdedit /set {GUID} device partition=C:
bcdedit /set {GUID} osdevice partition=C:
bcdedit /set {GUID} path \Windows\system32\winload.exe
bcdedit /set {GUID} systemroot \Windows
bcdedit /default {GUID}
bcdedit /displayorder {GUID} /addlast
bcdedit /timeout 10

"C" in all of the above commands should be replaced (if not correct) with the correct drive letter of the W7 partition, when it is booted.
Then you should be able to get into W7 from Grub, and you can run EasybCD to delete the NeoGrub entry (since you wont need it anymore).
 
Last edited:

EL84

New Member
#7
Thank you for the detailed instructions, I will try those as soon as I can find my USB because I need to make a bootable windows disk to access that startup recovery/ms-dos prompt.

In the mean time, I re-updated my packages after I installed the new GRUB and it asked me (in the details) if I want to create a menu.lst since one never existed. I found this funny since you said the new grub doesnt even use a menu.lst but I let it create one anyway. I uploaded what was created for you.

edit: its also still at v 1.97 beta.. hmm
 

Attachments

Last edited:
#8
Weird...
Maybe that's an earlier version of Grub2 or something. I don't know.

But it is evident by this entry that its aware of the Grub2 kernel for sure:
title Chainload into GRUB 2
root d542799d-1e62-494a-94a2-1c3d3bc59265
kernel /boot/grub/core.img
And this menu.lst does not contain an entry to boot Windows 7. You're going to have to add one manually.
Can you try the Grub commands I posted above again? Maybe now that Grub is updated, you will be able to run the commands.

EDIT: No, I think I know what it is...
Grub detected you have both versions on: Grub Legacy and Grub2.
So it automatically "combined" the two in a sense so you can either boot the legacy kernel or the Grub2 kernel.
 
Last edited:

EL84

New Member
#9
Just tried and got

grub> root (hd0,2)

grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... no

Error 15: File not found

grub>
Maybe I need to uninstall GRUB and reinstall it but god forbid I restart before I put it back on my system not only will I have no bootloader but no operating systems that work! lol
 
#10
I mentioned above (before editing the post) that "root (hd0,2)" was wrong, and you need to do "root (hd0,1)" instead since the Ubuntu partition is the second partition, not the third like I assumed from your first post.
So try the root (hd0,1) instead, and see if you obtain any different results.

Addendum:

And keep in mind there's always an easier way...
Super Grub Disk like I mentioned above...except for the fact you have no CD-ROM drive. :grinning:
 
Last edited:
#11
Getting the same problem. I'll try possibly burning the Super Grub Disc onto a USB and cross my fingers... Will report back with results :smile:
 
#12
Oh well...probably due to the fact you're using a stranger version of Grub than I'm familiar with. :smile:
This one doesn't want to play nice.
 

mqudsi

Mostly Harmless
Staff member
#13
Why don't you repair the Windows 7 bootloader then add a Fedora entry to it?
 
#14
going to try to do a startup repair today. I used unetbootin to burn super grub disk to a usb and ran a lot of the recovery options with NO luck. I almost crippled my system with it actually..

This is my last resort or else I will just reinstall 7 fresh & clean